Sage 9.5.rc2 release

138 views
Skip to first unread message

Volker Braun

unread,
Jan 16, 2022, 12:17:36 PMJan 16
to sage-release
As always, you can get the latest beta version from the "develop" git branch. Alternatively, the self-contained source tarball is at http://www.sagemath.org/download-latest.html

f9b2db94f6 (tag: 9.5.rc2, trac/develop) Updated SageMath version to 9.5.rc2
7a9347dbc0 Trac #33155: Broken install using system pythons < 3.10 from python.org macOS packages
fe634f8613 Trac #33162: Fix installation of cryptominisat and pycryptosat
9ceaaea7a7 Trac #33153: opensuse-tumbleweed: sagelib build fails
3da1b22c25 (tag: 9.5.rc1) Updated SageMath version to 9.5.rc1

jonatha...@googlemail.com

unread,
Jan 16, 2022, 4:42:06 PMJan 16
to sage-release
Thanks Volker for preparing the release.

All tests pass on debian buster, except

sage -t --long --random-seed=146168601452887490256495561253701871534 src/sage/tests/cmdline.py  # 3 doctests failed                                                               
as squlite executable is not available.

Matthias Köppe

unread,
Jan 16, 2022, 5:09:02 PMJan 16
to sage-release
The sqlite doctest failure is tracked at https://trac.sagemath.org/ticket/29092

Kenji Iohara

unread,
Jan 17, 2022, 5:05:50 AMJan 17
to sage-r...@googlegroups.com
Failed compilation from the first built, owing to r-3.6.3…
Here is the log-file:
r-3.6.3.log

Dima Pasechnik

unread,
Jan 17, 2022, 5:20:42 AMJan 17
to sage-release
On Mon, Jan 17, 2022 at 10:05 AM Kenji Iohara <simplye...@gmail.com> wrote:
>
> Failed compilation from the first built, owing to r-3.6.3…
> Here is the log-file:

checking for curl-config... /usr/local/anaconda3/bin/curl-config
checking libcurl version ... 7.78.0
checking curl/curl.h usability... yes
checking curl/curl.h presence... yes
checking for curl/curl.h... yes
checking if libcurl is version 7 and >= 7.22.0... no
configure: error: libcurl >= 7.22.0 library and headers are required

Are you mixing in conda libraries?
Unless this is a conda build, this most probably won't work.

If it's not a conda build then /usr/local/anaconda3/bin should not
be in your PATH, but it seems it is.



>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/5955FFF1-EB87-49E1-A3DF-C77E7C5E2424%40gmail.com.
> Even with pré-installed r-4.1.2, it didn’t work.
>
> 16/01/2022 23:09、Matthias Köppe <matthia...@gmail.com>のメール:
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/8bf9bc5c-73db-406c-9cc3-3040d2b7764bn%40googlegroups.com.
>
>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/5955FFF1-EB87-49E1-A3DF-C77E7C5E2424%40gmail.com.

Kenji Iohara

unread,
Jan 17, 2022, 8:50:29 AMJan 17
to sage-r...@googlegroups.com
Thanks Dima, removing anacoda, The first built on Mac OS 12.1 worked, with python 3.10.1.

17/01/2022 11:20、Dima Pasechnik <dim...@gmail.com>のメール:

Marc Culler

unread,
Jan 17, 2022, 4:13:38 PMJan 17
to sage-release

Adding $(PYTHON_TOOLCHAIN) to the cryptominisat dependencies fixed the build failure that I encountered.

Marc Culler

unread,
Jan 17, 2022, 4:13:38 PMJan 17
to sage-release
My attempt to build rc2 on macOS with arm CPU failed with this error:

Installing cryptominisat-5.6.8
/private/var/tmp/sage-9.5-current/local/var/lib/sage/venv-python3.9.9/bin/python3: No module named pip

Maybe a pip dependency is missing now for cryptominisat?

- Marc
On Sunday, January 16, 2022 at 4:09:02 PM UTC-6 matthia...@gmail.com wrote:

Samuel Lelièvre

unread,
Jan 19, 2022, 1:11:03 AMJan 19
to sage-release
2022-01-16 17:17 UTC, Volker Braun:
>
> f9b2db94f6 (tag: 9.5.rc2, trac/develop) Updated SageMath version to 9.5.rc2

Thanks Volker for this new release candidate.

On Cygwin 3.3.3-1 on Windows 10, build fails for me while trying
to build `sagemath_doc_html-none`, with or without ticket #33078,
as it has for the last few development versions. Logs:

- https://aij.ovh/sage/logs/slel-2022-01-17-cyg-sage-9-5-c2-33078.zip
- https://aij.ovh/sage/logs/slel-2022-01-17-cyg-sage-9-5-c2-fresh-clone-000.zip

Others have reported success building on Cygwin though,
so I guess I should clean up my Cygwin: maybe uninstall
some packages that are installed but not needed for Sage;
or reinstall Cygwin from scratch.

But I see Sage 9.5.rc3 is out, I'll try that one too. --Samuel

Marc Culler

unread,
Jan 21, 2022, 2:31:36 AMJan 21
to sage-release
I have resolved all of the issues I know of in the binary prelease of sage 9.5 https://github.com/3-manifolds/Sage_macOS/releases/download/v1.3-rc1/SageMath-9.5_arm64.dmg .

I switched to using the homebrew version of gfortran-11.  That resolved the crash when importing sage.manifolds.manifold (which was actually happening when importing the scpy integration module.)  I believe that the problem was that the other gfortran compiler implements fortran 2018 and some of the scipy modules are not compliant with that.

I also added a copy of the gfortran runtime, suitably adjusted to work in the Sage framework in the app bundle.

Matthias, I think you should revise your recommendation so it specifies the homebrew gfortran-11.

Matthias Köppe

unread,
Jan 21, 2022, 12:58:42 PMJan 21
to sage-release

Marc Culler

unread,
Jan 21, 2022, 4:09:14 PMJan 21
to sage-r...@googlegroups.com
Thanks, Matthias.  It is actually 9.5.rc2 now.

--
You received this message because you are subscribed to a topic in the Google Groups "sage-release" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/sage-release/Tm55GKQccq8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to sage-release...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/39a92f87-27ad-4ee2-869e-2ff3377d4c08n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages