Sage 9.7.beta2 released

113 views
Skip to first unread message

Volker Braun

unread,
Jun 12, 2022, 9:16:00 AMJun 12
to sage-release
As always, you can get the latest beta version from the "develop" git branch. Alternatively, the self-contained source tarball is at http://www.sagemath.org/download-latest.html

a6e696e91d (tag: 9.7.beta2, trac/develop) Updated SageMath version to 9.7.beta2
b95c1659af Trac #33865: direct computation of .formal()[1] for elliptic-curve morphisms
f0068fad25 Trac #33244: sage.arith.misc.power_mod() works in any ring with %, not just ZZ
9de47303c2 Trac #15426: Performance of casting ZZ[x] to Qp[x]
93619a4835 Trac #33959: some improvements in sandpile.py
d31947813b Trac #33958: cleaning two files in graphs/
f8cb451fb6 Trac #33954: partial pep cleanup for sandpile.py
2ae859211b Trac #33948: fix pycodestyle E306 in all pyx files
93c1512579 Trac #33944: saving a tikzpicture to a local folder is now broken
b99762ba0c Trac #33943: 1 doctest failing in oeis.py
7280939142 Trac #33937: finite-field .extension() sets up wrong coercion
fed1e4e89a Trac #33935: simplify some super(something) to super() outside of combinat
1ffc363fae Trac #33934: simplify some super(something) to super() inside combinat/
c7e0784afe Trac #33913: FPLLL 5.4.2 and FPyLLL 0.5.7
1551d4fa23 Trac #33885: Reference undefined - pdf documentation
06efaa3178 Trac #33879: Run pytest on github workflow for pytest related tickets
df2124f237 Trac #33822: python3 spkg-configure.m4: Require ensurepip
96a04a85fe Trac #33745: Create direct sum of matroids
4c932d04a3 Trac #32072: trace of zero fails in padic extensions
8d796b6441 Trac #29941: Modularization of sagelib: Break out separate packages sagemath-environment, sagemath-repl
f112639e6d Trac #24949: Bug in p-adic expansion over ramified extensions
da5e1ac57d Trac #23575: Geometric Frobenius is broken
67e08a3876 Trac #33933: Remove quickref and tutorial from sage.combinat.all
9fdcb698e0 Trac #32137: Update ncurses to 6.3 and readline to 8.1.2
0947cd9036 Trac #33930: failing doctest involving polymake and number field
222216c763 Trac #33924: pep cleanup for giac and gp pexpect interfaces
17438c198d Trac #33911: remove class inheritance of object in misc, repl, libs
2537707a5f Trac #33852: bootstrap, src/doc/Makefile: Remove use of the SAGE_ROOT/sage script
b15c91d8ae Trac #33926: Fix tox-docker builds
4ec6965256 Trac #32631: Typo in random_element of polynomial rings
4d74388add Trac #33912: remove trailing spaces in combinat
881da74fb0 Trac #33903: remove deprecation in nonexact.py
578204f49d Trac #33899: some fixes in arxiv links
8b8f67a9ad Trac #33889: get rid of some range(0,*) in pyx files
8d8c044584 Trac #33691: some care for pep8 in pyx in modular
fbf034fdb2 Trac #33557: FormalPolyhedraModule should check polyhedra for dimension
9015204871 Trac #31017: build/bin/sage-spkg-info: Format dependencies file; remove redundant "dependencies" sections from SPKG.rst
f5e8c5997a Trac #33916: tweak tox.ini: activate more pycodestyle checks in cython files
564609f061 Trac #33914: remove class inheritance of object in rings,structure,numerical,doctests
3853878b0a Trac #33910: installing jupyterlab causes sagelib rebuild
4d66bc90bb Trac #33905: pep and other details in dynamics
603a833979 Trac #33901: sage-bootstrap-python doesn't work when pyenv shadows all usable pythons in PATH
788281e061 Trac #33739: Migrate gitpod to conda
c2ca6af620 Trac #33601: Documentation: Add 'furo' theme
a340bda639 Trac #33544: Use language_level=3 for Cython everywhere
fa1477350a Trac #32937: Drop Python 3.7 support in Sage 9.7
a8c488f4a2 Trac #31937: Update markupsafe to 2.1.1, jinja2 to 3.1.2
cda7f69354 Trac #33917: Avoid Python 3.10 syntax in doctest introduced in #33799
70ec4e67ab Trac #25872: Modular decomposition bug
5fb2a6ea44 (tag: 9.7.beta1) Updated SageMath version to 9.7.beta1

Matthias Köppe

unread,
Jun 12, 2022, 1:38:36 PMJun 12
to sage-release
On Sunday, June 12, 2022 at 6:16:00 AM UTC-7 Volker Braun wrote:
a6e696e91d (tag: 9.7.beta2, trac/develop) Updated SageMath version to 9.7.beta2
[...] 
fa1477350a Trac #32937: Drop Python 3.7 support in Sage 9.7

Python 3.8 language and library features can now be used in the Sage library 
:= Goo goo g'joob

 

David Coudert

unread,
Jun 14, 2022, 4:57:08 AMJun 14
to sage-r...@googlegroups.com
I have issues compiling this release. I have openblas 0.3.20 installed with homebrew, but sage searches for 0.3.19.

laptop: Macbook air (Intel) with macOS 12.3.1

sapristi:sage dcoudert$ gcc --version
Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX12.3.sdk/usr/include/c++/4.2.1
Apple clang version 13.0.0 (clang-1300.0.27.3)
Target: x86_64-apple-darwin21.4.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin

log file attached. Let me know if you need more data.

Thank you in advance for your help.

Best,
David.



install.log

Dima Pasechnik

unread,
Jun 14, 2022, 5:06:24 AMJun 14
to sage-release
On Tue, Jun 14, 2022 at 9:57 AM David Coudert <david....@gmail.com> wrote:
>
> I have issues compiling this release. I have openblas 0.3.20 installed with homebrew, but sage searches for 0.3.19.

looks like you have a stale ./configure, otherwise I can't explain this.
Run

./bootstrap

(making sure it succeeds)

>
> laptop: Macbook air (Intel) with macOS 12.3.1
>
> sapristi:sage dcoudert$ gcc --version
> Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX12.3.sdk/usr/include/c++/4.2.1
> Apple clang version 13.0.0 (clang-1300.0.27.3)
> Target: x86_64-apple-darwin21.4.0
> Thread model: posix
> InstalledDir: /Library/Developer/CommandLineTools/usr/bin
>
> log file attached. Let me know if you need more data.
>
> Thank you in advance for your help.
>
> Best,
> David.
>
>
>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/EA0693C7-7391-4E07-8F58-982A7D415083%40gmail.com.
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/4251cff7-e641-44f3-9a41-23a56bc5f081n%40googlegroups.com.
>
>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/EA0693C7-7391-4E07-8F58-982A7D415083%40gmail.com.

Dima Pasechnik

unread,
Jun 14, 2022, 5:16:06 AMJun 14
to sage-release
On Tue, Jun 14, 2022 at 10:06 AM Dima Pasechnik <dim...@gmail.com> wrote:
>
> On Tue, Jun 14, 2022 at 9:57 AM David Coudert <david....@gmail.com> wrote:
> >
> > I have issues compiling this release. I have openblas 0.3.20 installed with homebrew, but sage searches for 0.3.19.
>
> looks like you have a stale ./configure, otherwise I can't explain this.
> Run
>
> ./bootstrap
>
> (making sure it succeeds)

In fact, the up to date ./configure will not even check that the
version is less than 0.3.20.
So I don't know what's happening, perhaps some mixup in your Homebrew, or
in the result of "source .homebrew-build-env"
It could be that the latter was not run since Homebrew update, and
still points (in, say, LIBRARY_PATH, or in PKG_CONFIG_PATH) at a no
longer existing on the system 0.3.19

Closing the shell, opening a fresh one, and
doing

source .homebrew-build-env

should fix this issue.

Emmanuel Charpentier

unread,
Jun 14, 2022, 5:36:22 AMJun 14
to sage-release
On Debian testing running on core i7 + 16 GB RAM, upgrading 9.7.beta1 to 9.7.beta2 and running ptestlong givest the same two permanent failures already reported for 9.7.beta1 (and no transient failure).

HTH

G. M.-S.

unread,
Jun 14, 2022, 8:03:38 AMJun 14
to sage-release

Thanks, Volker.

This is on Apple Silicon Macs with Homebrew up to date and make pytest.

About OpenBLAS:  Version 0.3.20 from Homebrew used, as seen in config.log:
openblas-0.3.20: using system package; SPKG will not be installed

macOS 11.6.7 (Big Sur) with Xcode 13.2.1:  make ptestlong gives the usual:
----------------------------------------------------------------------
sage -t --long --warn-long 48.3 --random-seed=153958501618775594540940591157976687080 src/sage/matrix/matrix_gf2e_dense.pyx  # 1 doctest failed
----------------------------------------------------------------------
(see https://trac.sagemath.org/ticket/33212 and https://bitbucket.org/malb/m4rie/issues/23/trying-to-compile-on-apple-m1).

macOS 12.4 (Monterey) with Xcode 13.4.1:  make ptestlong gives no errors.

Guillermo

Henri Girard

unread,
Jun 14, 2022, 8:59:53 AMJun 14
to sage-r...@googlegroups.com
build on AMD ryzen 16 coeurs 16 Go RAM 1Tera ssd with ubuntu dev 22.10
(beta)  no problem

David Coudert

unread,
Jun 15, 2022, 2:40:23 AMJun 15
to sage-r...@googlegroups.com
After « make distclean », starting a fresh shell, "./bootstrap", "source .homebrew-build-env », "./configure » and « make build », I now have an error at the end of the compilation of maxima.

[maxima-5.45.0.p0] Now installing the Maxima library as '/Users/dcoudert/sage/local/lib/ecl/maxima.fas'...
[maxima-5.45.0.p0] cp: src/binary-ecl/maxima.fas: No such file or directory
[maxima-5.45.0.p0] ********************************************************************************
[maxima-5.45.0.p0] Failed to install 'src/binary-ecl/maxima.fas' as
[maxima-5.45.0.p0] '/Users/dcoudert/sage/local/lib/ecl/maxima.fas'.

Log file attached.

Best,
David.
install.log

Dima Pasechnik

unread,
Jun 15, 2022, 3:21:03 AMJun 15
to sage-release
errors such as
[maxima-5.45.0.p0] ;;; Loading
"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/../lisp-utils/defsys
tem.lisp"
[maxima-5.45.0.p0] ;;; Loading
#P"/usr/local/Cellar/ecl/21.2.1_2/lib/ecl-21.2.1/cmp.fas"
[maxima-5.45.0.p0]
#P"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/lisp-utils/defsystem.lisp"
[maxima-5.45.0.p0] >
[maxima-5.45.0.p0] ("../src/" "./" (MAKE::HOME-SUBDIRECTORY "lisp/systems/")
[maxima-5.45.0.p0] "/usr/local/lisp/Registry/")
[maxima-5.45.0.p0] >
[maxima-5.45.0.p0] ;;; Loading
"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/maxima.system"
[maxima-5.45.0.p0]
[maxima-5.45.0.p0] ; - Compiling defsystem "maxima"
[maxima-5.45.0.p0] ; - Compiling module "package"
[maxima-5.45.0.p0] ; - Compiling source file
[maxima-5.45.0.p0] ;
"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/maxima-package.lisp"
[maxima-5.45.0.p0] ;;;
[maxima-5.45.0.p0] ;;; Compiling
/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/maxima-package.lisp
.
[maxima-5.45.0.p0] ;;; OPTIMIZE levels: Safety=2, Space=0, Speed=3, Debug=2
[maxima-5.45.0.p0] ;;;
[maxima-5.45.0.p0] ;;; End of Pass 1.
[maxima-5.45.0.p0] ;;; Internal error:
[maxima-5.45.0.p0] ;;; ** Detected access to an invalid or protected
memory address.
[maxima-5.45.0.p0] ; - Binary file binary-ecl/maxima-package.fas
is old or does not exist.
[maxima-5.45.0.p0] ; Compile (and load) source file
/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/maxima-package.lisp
instead? y
[maxima-5.45.0.p0] ; - Should I bother you if this happens again? y
[maxima-5.45.0.p0] ; - Compiling source file
[maxima-5.45.0.p0] ;
"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/maxima-package.lisp"
[maxima-5.45.0.p0] ;;;
[maxima-5.45.0.p0] ;;; Compiling
/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/maxima-package.lisp.
[maxima-5.45.0.p0] ;;; Internal error:
[maxima-5.45.0.p0] ;;; ** Internal error: stream #<output stream
#P"binary-ecl/maxima-package.c" 0x10f70c140> has no valid C file
handler.
[maxima-5.45.0.p0] ; - Loading binary file "binary-ecl/maxima-package.fas"
[maxima-5.45.0.p0] Condition of type: FILE-ERROR
[maxima-5.45.0.p0] Filesystem error with pathname
#P"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/binary-ecl/maxima-package.fas".



Are you out of disk space?
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/AB87A44E-531C-4645-AA12-8ADB83F3DBEE%40gmail.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/CAAWYfq1omEA%2BZSb80XNoZmccsp_ikAZENskEefvZQggTtZZqQg%40mail.gmail.com.
>
>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/AB87A44E-531C-4645-AA12-8ADB83F3DBEE%40gmail.com.

David Coudert

unread,
Jun 15, 2022, 3:26:26 AMJun 15
to sage-r...@googlegroups.com
No, I have enough free space on disk

sapristi:sage dcoudert$ df -h .
Filesystem     Size   Used  Avail Capacity iused      ifree %iused  Mounted on
/dev/disk1s2  932Gi  475Gi  422Gi    53% 3172816 4424250640    0%   /System/Volumes/Data


May be it is due to F-Secure ? I’m forced to used this software and I’m not able to switch it off, even temporarily :(

David.

Dima Pasechnik

unread,
Jun 15, 2022, 3:51:32 AMJun 15
to sage-release
On Wed, Jun 15, 2022 at 8:26 AM David Coudert <david....@gmail.com> wrote:
>
> No, I have enough free space on disk
>
> sapristi:sage dcoudert$ df -h .
> Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
> /dev/disk1s2 932Gi 475Gi 422Gi 53% 3172816 4424250640 0% /System/Volumes/Data
>
>
> May be it is due to F-Secure ? I’m forced to used this software and I’m not able to switch it off, even temporarily :(

It might be. I have no idea about F-Secure. Perhaps it does not like
ecl you use?

It could be that ecl is broken (I presume you use one from Homebrew)
Can you start it and check if

(+ 2 2)

produces 4?
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/81AFD614-D00D-41AB-949A-9ECE784DBC8D%40gmail.com.

David Coudert

unread,
Jun 15, 2022, 4:36:33 AMJun 15
to sage-r...@googlegroups.com
It produces 4

sapristi:sage dcoudert$ ecl
ECL (Embeddable Common-Lisp) 21.2.1 (git:UNKNOWN)
Copyright (C) 1984 Taiichi Yuasa and Masami Hagiya
Copyright (C) 1993 Giuseppe Attardi
Copyright (C) 2013 Juan J. Garcia-Ripoll
Copyright (C) 2018 Daniel Kochmanski
Copyright (C) 2021 Daniel Kochmanski and Marius Gerbershagen
ECL is free software, and you are welcome to redistribute it
under certain conditions; see file 'Copyright' for details.
Type :h for Help.  
Top level in: #<process TOP-LEVEL 0x10219ff80>.
> (+ 2 2)

4


Dima Pasechnik

unread,
Jun 15, 2022, 4:39:32 AMJun 15
to sage-release
OK, maybe there is a bit more info in
logs/pkgs/maxima-5.45.0.p0.log
?
could you post it, and top-level config.log ?
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/2E7F052B-9253-4C5E-A6B3-EB681A1C20A7%40gmail.com.

David Coudert

unread,
Jun 15, 2022, 6:02:27 AMJun 15
to sage-r...@googlegroups.com
attached.
Thank you Dima.


maxima-5.45.0.p0.log
config.log

Dima Pasechnik

unread,
Jun 15, 2022, 8:20:42 AMJun 15
to sage-release
Do you have /usr/local/lisp/Registry/ ?
(not writable for the normal user?)
Cf the part of the ecl log below.


On Wed, Jun 15, 2022 at 11:02 AM David Coudert <david....@gmail.com> wrote:
>
> attached.


;;; Loading "/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/../lisp-utils/defsystem.lisp"
;;; Loading #P"/usr/local/Cellar/ecl/21.2.1_2/lib/ecl-21.2.1/cmp.fas"
#P"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/lisp-utils/defsystem.lisp"
>
("../src/" "./" (MAKE::HOME-SUBDIRECTORY "lisp/systems/")
"/usr/local/lisp/Registry/")
>
;;; Loading "/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/../lisp-utils/make-depends.lisp"
#P"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/lisp-utils/make-depends.lisp"
>
Condition of type: SEGMENTATION-VIOLATION
Detected access to an invalid or protected memory address.

Available restarts:

1. (CONTINUE) Ignore signal
2. (RESTART-TOPLEVEL) Go back to Top-Level REPL.

Broken at MAKE::CREATE-DEPENDENCY-FILE. In: #<process TOP-LEVEL 0x10c376f80>.
File: #P"/Users/dcoudert/sage/local/var/tmp/sage/build/maxima-5.45.0.p0/src/src/../lisp-utils/make-depends.lisp"
(Position #677)
>>



> Thank you Dima.
>
>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/22E52DB7-4911-4423-B411-912018742DFB%40gmail.com.
> > To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/CAAWYfq2DAD%2BJHD1ioE9qKpyk2ge7QDTqKunQfRV49Xwvwfs%2BbA%40mail.gmail.com.
>
> --
> You received this message because you are subscribed to the Google Groups "sage-release" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-release...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/22E52DB7-4911-4423-B411-912018742DFB%40gmail.com.

David Coudert

unread,
Jun 15, 2022, 8:42:47 AMJun 15
to sage-r...@googlegroups.com
I don’t have /usr/local/lisp at all.
Should I (try to) install it ? Not sure how…

David.

Dima Pasechnik

unread,
Jun 15, 2022, 9:07:33 AMJun 15
to sage-release
On Wed, Jun 15, 2022 at 1:42 PM David Coudert <david....@gmail.com> wrote:
>
> I don’t have /usr/local/lisp at all.
> Should I (try to) install it ?

no, this should not be needed.



> Not sure how…

(anti)virus?
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/E7BE578E-B1CF-4380-8467-B306B4D59CB1%40gmail.com.

David Coudert

unread,
Jun 15, 2022, 1:33:41 PMJun 15
to sage-r...@googlegroups.com
It seems that F-Secure is fighting against me.
I tried again and succeed to compile maxima. How ? I was in front of my computer and I saw a popup from F-Secure asking me if it’s ok to let ecl access my hard drive…

Let’s hope I will not have to be in front of my computer all the time. Compiling Sagemath is quite long on a MacBook Air.

Best,
David.

G. M.-S.

unread,
Jun 15, 2022, 2:31:32 PMJun 15
to sage-release

Regarding F-Secure, I suggest sending this link to whomever is responsible for it:


Bon courage !

Guillermo

David Coudert

unread,
Jun 16, 2022, 7:30:09 AMJun 16
to sage-r...@googlegroups.com
I have finally succeeded to compile Sageamath.
My difficulties are clearly due to F-Secure. It opens popups from time to time to ask if a subprocess (e.g., ecl) can access the hard drive, and if you don’t answer it takes it as a no and the compilation fails.

I will contact my IT service to complain.

Thank you for your help,
David.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-release/CAAWYfq0r4wF%3D2gR1Da65P3RsC5j6-pE%2BB6sQstq%2B1YF0_ZsEYw%40mail.gmail.com.

Eric Gourgoulhon

unread,
Jun 16, 2022, 8:56:46 AMJun 16
to sage-release
Thanks for the new release.
On Ubuntu 20.04 running on Xeon E5-2623 + 16 GB RAM:

- incremental build (-j16) from Sage 9.7.beta1: OK (but see below)
- make ptestlong --> "All tests passed!"

Side note: this is the first version of Sage that refuses to use the system Python, which is 3.8.10. Although only Python 3.7 is officially dropped by this version, configure says:
 
checking for python3 >= 3.8.0, < 3.11.0 with modules sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip...
checking ... whether /usr/bin/python3 is good... no, the version is in the supported range but cannot import one of the required modules: sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip

Consequently, Python 3.10.3 was installed as a SPKG during Sage build.

Eric.


Le dimanche 12 juin 2022 à 15:16:00 UTC+2, Volker Braun a écrit :

Justin C. Walker

unread,
Jun 17, 2022, 2:22:30 AMJun 17
to sage-r...@googlegroups.com


> On Jun 12, 2022, at 06:16 , Volker Braun <vbrau...@gmail.com> wrote:
>
> As always, you can get the latest beta version from the "develop" git branch. Alternatively, the self-contained source tarball is at http://www.sagemath.org/download-latest.html

Built on two systems (10.14.6 - 2017 MBP, Quad-core Core -7; 10.15.7 - 2019 8-core Core i9).

10.15.7: no problems with build, all tests (‘ptestlong’) passed!

10.14.6: no problems with build, testing (‘ptestlong’) yielded the usual failure, which seems permanent.
Log file snippet attached.

Justin

9.7.b2.log

Matthias Köppe

unread,
Jun 17, 2022, 1:49:31 PMJun 17
to sage-release
On Thursday, June 16, 2022 at 5:56:46 AM UTC-7 egourg...@gmail.com wrote:
this is the first version of Sage that refuses to use the system Python, which is 3.8.10. Although only Python 3.7 is officially dropped by this version, configure says:
 
checking for python3 >= 3.8.0, < 3.11.0 with modules sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip...
checking ... whether /usr/bin/python3 is good... no, the version is in the supported range but cannot import one of the required modules: sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip

 You may need to install the package "python3-venv".
 
Le dimanche 12 juin 2022 à 15:16:00 UTC+2, Volker Braun a écrit :
As always, you can get the latest beta version from the "develop" git branch. Alternatively, the self-contained source tarball is at http://www.sagemath.org/download-latest.html

a6e696e91d (tag: 9.7.beta2, trac/develop) Updated SageMath version to 9.7.beta2
[...]

Eric Gourgoulhon

unread,
Jun 20, 2022, 8:20:33 AMJun 20
to sage-release
Le vendredi 17 juin 2022 à 19:49:31 UTC+2, matthia...@gmail.com a écrit :
On Thursday, June 16, 2022 at 5:56:46 AM UTC-7 egourg...@gmail.com wrote:
this is the first version of Sage that refuses to use the system Python, which is 3.8.10. Although only Python 3.7 is officially dropped by this version, configure says:
 
checking for python3 >= 3.8.0, < 3.11.0 with modules sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip...
checking ... whether /usr/bin/python3 is good... no, the version is in the supported range but cannot import one of the required modules: sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip

 You may need to install the package "python3-venv".

Indeed, this solves the issue, thanks!
After having installed python3-venv, I could build Sage 9.7.beta3 from a fresh git clone with the system Python (3.8.10).
I've updated
accordingly.

Eric. 
Reply all
Reply to author
Forward
0 new messages