Doctest hangs on aarch64

10 views
Skip to first unread message

Timo Kaufmann

unread,
Aug 14, 2019, 8:24:39 AM8/14/19
to sage-packaging
When running the tests on an aarch64 machine, I get random hangs in the doctests. Here are the hangs of 6 full runs of the testsuite (separated by blank lines):

sage -t --long src/sage/combinat/species/library.py # Timed out
sage -t --long src/sage/groups/perm_gps/partn_ref/data_structures.pyx # Timed out
sage -t --long src/sage/groups/perm_gps/permgroup.py # Timed out

sage -t --long src/sage/combinat/integer_vectors_mod_permgroup.py # Timed out

sage -t --long src/sage/groups/perm_gps/permgroup.py # Timed out
sage -t --long src/sage/rings/number_field/number_field_element.pyx # Timed out

sage -t --long src/sage/combinat/integer_vectors_mod_permgroup.py # Timed out
sage -t --long src/sage/groups/perm_gps/partn_ref/data_structures.pyx # Timed out

sage -t --long src/sage/combinat/constellation.py # Timed out
sage -t --long src/sage/rings/number_field/number_field_element.pyx # Timed out
sage -t --long src/sage/tests/books/judson-abstract-algebra/sylow-sage.py # Timed out

sage -t --long src/sage/modular/arithgroup/congroup_gammaH.py # Timed out

I'm hoping that someone more knowledgeable about the implementation can spot a pattern here. Any particular dependency that may be the root cause? Most failures seem to be group related. Here's one of the full logs: https://gist.github.com/timokau/950b9f6c9d2107255dcb7956dda76fcb

Any ideas?

Dima Pasechnik

unread,
Aug 14, 2019, 11:47:59 AM8/14/19
to sage-packaging
Did you try building GAP spkg on that ARM machine with SAGE_CHECK=yes ?
> --
> You received this message because you are subscribed to the Google Groups "sage-packaging" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-packagin...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-packaging/6907e2f3-9927-47c6-9f13-6617797b85f5%40googlegroups.com.

Timo Kaufmann

unread,
Aug 14, 2019, 2:55:22 PM8/14/19
to sage-packaging

Am Mittwoch, 14. August 2019 15:47:59 UTC schrieb Dima Pasechnik:
Did you try building GAP spkg on that ARM machine with SAGE_CHECK=yes ?

Thanks for taking a look! This being on-distro, I'm not using the spkg. But our gap package does run gaps "testinstall" test suite (the same one the spkg runs) and those pass. Prompted by your reply I also tried running the more extensive "teststandard". It passed, but there was one noticable outlier: `ctbl.tst` took ~1h to run and allocated 280GB of memory, while most other tests only took milliseconds and allocate kilobytes. I get similar results on x86 however, so that is probably not the cause.
Reply all
Reply to author
Forward
0 new messages