trouble compiling singular

43 views
Skip to first unread message

moritz

unread,
Jan 12, 2017, 3:12:48 AM1/12/17
to sage-devel
[I tried to post already yesterday, but my message somehow didn't get through]

When trying to build sage (the current develop-branch 7.5) I get an error on my debian box with a current sid-install.

For the end of the logfile, see the end of this post. It also throws some of the following errors:

polymake_conversion.cc:176:56: error: cannot convert 'pm::array_traits<pm::Integer>::iterator {aka pm::ptr_wrapper<pm::Integer, false>}' to 'const pm::Integer*' in initialization

I will gladly attach the entire log file, if that helps.

part of logs/pkgs/singular-4.1.0p1.log:

../../../gfanlib/gfanlib_matrix.h: In instantiation of 'gfan::Matrix<typ>::RowRef& gfan::Matrix<typ>::RowRef::operator=(const gfan::Vector<typ>&) [with typ = gfan::Rational]':
../../../gfanlib/gfanlib_matrix.h:777:57:   required from here
../../../gfanlib/gfanlib_matrix.h:221:24: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
         assert(v.size()==matrix.width);
                        ^
../../../gfanlib/gfanlib_matrix.h: In instantiation of 'gfan::Matrix<typ>::RowRef& gfan::Matrix<typ>::RowRef::operator=(const gfan::Vector<typ>&) [with typ = gfan::Integer]':
../../../gfanlib/gfanlib_matrix.h:784:66:   required from here
../../../gfanlib/gfanlib_matrix.h:221:24: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
../../../gfanlib/gfanlib_matrix.h: In instantiation of 'gfan::Matrix<typ>::RowRef& gfan::Matrix<typ>::RowRef::operator=(const gfan::Vector<typ>&) [with typ = int]':
../../../gfanlib/gfanlib_matrix.h:792:59:   required from here
../../../gfanlib/gfanlib_matrix.h:221:24: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
Makefile:573: recipe for target 'polymake_la-polymake_conversion.lo' failed
make[8]: *** [polymake_la-polymake_conversion.lo] Error 1



moritz

unread,
Jan 12, 2017, 5:53:19 AM1/12/17
to sage-devel
I figured out what the problem was: I had a version of polymake installed (3.0.6) and singular checks for a polymake install. However when I removed polymake and polymake-config from /usr/local/bin sage could be build successfully. When configuring singular one could also pass the --disable-polymake flag.

I hope somebody with a similar problem might find this useful..

Dima Pasechnik

unread,
Jan 12, 2017, 7:17:44 AM1/12/17
to sage-devel
Thanks for the report.
Sage has an experimental polymake package: https://trac.sagemath.org/ticket/20892

Not sure if we ever checked how well it lives together with Singular --- but we should.
Reply all
Reply to author
Forward
0 new messages