Build error instructed me to post a message here

30 views
Skip to first unread message

bruno edwards

unread,
Nov 4, 2022, 2:29:55 PM11/4/22
to sage-devel
Hi, I've been getting this error when trying to build sage - any ideas?

I've tried running the subshell command, but I still get an error - see the attached output.

I've also attached my neofetch output containing system specs

Thanks in advance,

Bruno

[gcc-11.3.0] ************************************************************************
[gcc-11.3.0] Error building package gcc-11.3.0
[gcc-11.3.0] ************************************************************************
[gcc-11.3.0] Please email sage-devel (http://groups.google.com/group/sage-devel)
[gcc-11.3.0] explaining the problem and including the log files
[gcc-11.3.0]   /media/EXTRA_PARTITION/sage/sage/logs/pkgs/gcc-11.3.0.log
[gcc-11.3.0] and
[gcc-11.3.0]   /media/EXTRA_PARTITION/sage/sage/config.log
[gcc-11.3.0] Describe your computer, operating system, etc.
[gcc-11.3.0] If you want to try to fix the problem yourself, *don't* just cd to
[gcc-11.3.0] /media/EXTRA_PARTITION/sage/sage/local/var/tmp/sage/build/gcc-11.3.0 and type 'make' or whatever is appropriate.
[gcc-11.3.0] Instead, the following commands setup all environment variables
[gcc-11.3.0] correctly and load a subshell for you to debug the error:
[gcc-11.3.0]   (cd '/media/EXTRA_PARTITION/sage/sage/local/var/tmp/sage/build/gcc-11.3.0' && '/media/EXTRA_PARTITION/sage/sage/sage' --buildsh)
[gcc-11.3.0] When you are done debugging, you can type "exit" to leave the subshell.
[gcc-11.3.0] ************************************************************************
gcc-11.3.0.log
config.log
neofetch_output.txt
subshell output.txt

Dima Pasechnik

unread,
Nov 4, 2022, 3:18:12 PM11/4/22
to sage-devel
avoid building gcc. You don't need it. Read advice on packages printed by ./configure at the end of run, and follow it.

I'd give you more details over a teams or google meet call.
(Bruno is one of our 3rd year students I advise this year).

Dima

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sage-devel/1e272c3d-213d-4e0c-8cec-be29d05513d6n%40googlegroups.com.

bruno edwards

unread,
Nov 5, 2022, 9:40:06 AM11/5/22
to sage-...@googlegroups.com
Hi Dima,

My ./configure tells me I have additional packages to install, but installing them seems not to change anything. e.g. the output from ./configure:

configure:

    notice: the following SPKGs did not find equivalent system packages:

        appdirs distlib filelock...


so I apt-get installed appdirs, python3-appdirs and python-appdirs, and even after successful installation, ./configure still gives the same message (including appdirs).

I never had these problems initially, but my computer has been acting up recently, so I think I might reinstall my OS.

Best,

Bruno

Reply all
Reply to author
Forward
0 new messages