Working directory of our github workflows is not SAGE_ROOT

Skip to first unread message

Kwankyu Lee

Aug 27, 2023, 10:27:49 PM8/27/23
to sage-devel

This is a part of our BUILD & TEST workflow script

      - name: Test all files (sage -t --all --long)
        if: always() && == 'success'
        run: |
          ../sage -python -m pip install coverage
          ../sage -python -m coverage run ./bin/sage-runtests --all --long -p2 --random-seed=286735480429121101562228604801325644303
        working-directory: ./worktree-image/src    

Why is the working directory "SAGE_ROOT/src" instead of "SAGE_ROOT"?

I often copy failed doctest commands from the terminal screen of the workflow job. And when I run the command, I should prepend "src/" to file paths. For example,

sage -t --long --random-seed=286735480429 sage/cpython/cython_metaclass.pyx  

If I run this command at SAGE_ROOT, it complains because of missing "src/".

The same annoyance is throughout our workflows.

Isn't this unavoidable?

Reply all
Reply to author
0 new messages