Make not using installed gcc and openssl

Skip to first unread message

Todd Hesla

Jun 11, 2024, 1:42:48 PMJun 11
to sage-devel

I'm trying to build Sagemath 10.3 from the source tarball in my new Fedora 40
system (details below), but am experiencing a problem with "make" not noticing
existing packages that are already installed on my system:


Instead, "make" built gcc-12.2.0 from the included source (which finished
successfully after many hours), and it tried to build openssl-3.0.12 from the
included source, but this aborted with an error (see the attached log file).

Is there any way to force "make" to use my existing "gcc" and "openssl"
packages, rather than trying to compile them from source (unsuccessfully in the
case of openssl)?  This would save many hours of compiling of "gcc" from source,
and would presumably circumvent the error building "openssl" from source.

I've attached the log files:



Todd Hesla
Minneapolis MN

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
System details:

  Operating System: Fedora Linux 40
  KDE Plasma Version: 6.0.5
  KDE Frameworks Version: 6.2.0
  Qt Version: 6.7.1
  Kernel Version: 6.8.11-300.fc40.x86_64 (64-bit)
  Graphics Platform: Wayland
  Processors: 8 x Intel Core i7 CPU 920 @ 2.67GHz
  Memory: 5.8 GiB of RAM
  Graphics Processor: llvmpipe

Jun 12, 2024, 10:55:36 AMJun 12
to sage-devel
I think there are two choices. One worked for me, just compile the last develop version. For the other one, there are some PR that can be applied, but I am not sure if it will work.
Reply all
Reply to author
0 new messages