Error building package python3-3.11.8

87 views
Skip to first unread message

Laurent anaguet

unread,
Jun 9, 2024, 8:22:34 PMJun 9
to sage-devel
Hi!
I tried to install sagemath-10.4-beta8 on xubuntu24.04 but it didn't work. I have a message:
 Error building package python3-3.11.8. What does it wrong? The file log is in attchment.
thanks!


python3-3.11.8.log

Matthias Koeppe

unread,
Jun 9, 2024, 8:54:02 PMJun 9
to sage-devel
This message from the log looks rather suspicious:

[spkg-build] running build
[spkg-build] running build_ext
[spkg-build] Header file /home/francois/T\�\�l\�\�chargements/sage-10.4.beta8/local/lib/libffi-3.2.1/include/ffi.h does not exist
[spkg-build] building 'array' extension


Dima Pasechnik

unread,
Jun 10, 2024, 7:02:14 AMJun 10
to sage-...@googlegroups.com
Why do you even need to build Python 3.11? Don't you have system-wide
3.12 which you can use?
It would help if you post full toplevel config.log.

It would also be good to put Sage to a directory which doesn't have
non-ASCII characters in the full path, and no spaces in it - it seems
it's not the case:

[spkg-build] Header file
/home/francois/T\�\�l\�\�chargements/sage-10.4.beta8/local/lib/libffi-3.2.1/include/ffi.h


> --
> You received this message because you are subscribed to the Google Groups "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/sage-devel/2d81071f-2c78-4a0e-8b97-db4f2baa18c3n%40googlegroups.com.

Laurent anaguet

unread,
Jun 13, 2024, 1:13:41 PMJun 13
to sage-devel
Thanks for your answer.
 How I can use my python3.12 system to build Sage?

Thank you.
install.log
Reply all
Reply to author
Forward
0 new messages