PolyBoRi requires boost library

31 views
Skip to first unread message

Jeroen Demeyer

unread,
May 17, 2012, 12:24:27 PM5/17/12
to sage-devel
As noted on sage-support, the sage-5.0 *binary* requires the boost
library libboost_unit_test_framework at runtime, if the binary was built
on such a machine. I.e. PolyBoRi checks for boost_unit_test_framework
and links against it if available.

This is because of the PolyBoRi upgrade to version 0.8.1. The older
PolyBoRi in sage-4.8 did not do this.

Ticket created: http://trac.sagemath.org/sage_trac/ticket/12963

Stephen Montgomery-Smith

unread,
May 17, 2012, 7:26:02 PM5/17/12
to sage-...@googlegroups.com
Just as a point of information, I had this issue with the FreeBSD port
of sage. I used the attached patch, which I guess is the right way to
switch this off. (Someone tell me if I got it wrong.)
spkg-patch-polybori-0.8.1.p1_-_custom.py
Reply all
Reply to author
Forward
0 new messages