But there is probably also a lot of code that relies on the list(m)
behavior. For example, this behavior is what allows m[0] to mean the
first row, which certainly is used a lot.
Maybe m.list() should be renamed to m.elements()? That way it's not
confusing, and it's also not confusing to have two ways to get the list
of elements.
Jason