merging gap_packages and database_gap spkgs into gap spkg

61 views
Skip to first unread message

Dima Pasechnik

unread,
Dec 15, 2018, 5:09:49 AM12/15/18
to sage-devel, sage-packaging
The present design with two optional packages gap_packages and
database_gap was dictated in the 1st place by copyright issues with
their contents, preventing them from being standard.

Since GAP release 4.9, all these issues have been resolved upstream,
and I propose these spkgs to be merged into the standard GAP spkg. The
upstream GAP tarball already contains everything we install there (and
more).

With this, Sage's GAP would be much closer to the upstream GAP, and
packagers of Sage would be made happier too.

As a part of the update to GAP 4.10, I've already merged database_gap
into gap spkg on
https://trac.sagemath.org/ticket/26856

Unless I hear well-motivated objections (no, don't tell me about big
tarballs and increased by 3 minutes build time), I'll proceed with
doing the same to gap_packages.

Dima

John Cremona

unread,
Dec 15, 2018, 7:28:32 AM12/15/18
to SAGE devel, sage-packaging
+1

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-...@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

David Roe

unread,
Dec 15, 2018, 2:27:53 PM12/15/18
to sage-devel, sage-pa...@googlegroups.com
That sounds great!
David

On Sat, Dec 15, 2018 at 7:28 AM John Cremona <john.c...@gmail.com> wrote:
+1

On 15 Dec 2018 10:09, "Dima Pasechnik" <dim...@gmail.com> wrote:
The present design with two optional packages gap_packages and
database_gap was dictated in the 1st place by copyright issues with
their contents, preventing them from being standard.

Since GAP release 4.9, all these issues have been resolved upstream,
and I propose these spkgs to be merged into the standard GAP spkg. The
upstream GAP tarball already contains everything we install there (and
more).

With this, Sage's GAP would be much closer to the upstream GAP, and
packagers of Sage would be made happier too.

As a part of the update to GAP 4.10, I've already merged database_gap
into gap spkg on
https://trac.sagemath.org/ticket/26856

Unless I hear well-motivated objections (no, don't tell me about big
tarballs and increased by 3 minutes build time), I'll proceed with
doing the same to gap_packages.

Dima

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+...@googlegroups.com.

To post to this group, send email to sage-...@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+...@googlegroups.com.

Simon King

unread,
Dec 16, 2018, 5:04:58 AM12/16/18
to sage-...@googlegroups.com
Hi Dima,

I'm installing database_gap and gap_packages anyway, so, I am +1 to
making them standard and I am happy that the licence problems have
finally been resolved.

Best regards,
Simon

David Joyner

unread,
Dec 16, 2018, 6:37:45 AM12/16/18
to sage-devel
+1

Travis Scrimshaw

unread,
Dec 16, 2018, 10:25:59 PM12/16/18
to sage-devel
+1
Reply all
Reply to author
Forward
0 new messages