Need contact who can provide direction on default jquery-ui theme for sage-notebook...

37 views
Skip to first unread message

Jonathan

unread,
Mar 24, 2014, 9:52:20 PM3/24/14
to sage-...@googlegroups.com
As I have posted to the sage-notebook list, I have pure javascript Jmol working in the notebook (see track ticket #16004: http://trac.sagemath.org/ticket/16004).  However, this requires an up-to-date version of jquery.  It appears that the jquery-ui-1.8.11 (about 3 years old) which we are using is not compatible.  Can somebody tell me what the theme choices were to roll an updated jquery-ui-1.10.4?

Thanks,
Jonathan

kcrisman

unread,
Mar 25, 2014, 10:02:53 AM3/25/14
to sage-...@googlegroups.com, jason...@creativetrax.com


As I have posted to the sage-notebook list, I have pure javascript Jmol working in the notebook (see track ticket #16004: http://trac.sagemath.org/ticket/16004).  However, this requires an up-to-date version of jquery.  It appears that the jquery-ui-1.8.11 (about 3 years old) which we are using is not compatible.  Can somebody tell me what the theme choices were to roll an updated jquery-ui-1.10.4?


I don't think it should be horrible to update, for a JS expert - for me, probably very horrible :)

Jason, what version of Jquery-ui do you use in the cell server?  Maybe that is a starting point for thinking about this.  

kcrisman

unread,
Mar 25, 2014, 10:04:12 AM3/25/14
to sage-...@googlegroups.com, jason...@creativetrax.com


As I have posted to the sage-notebook list, I have pure javascript Jmol working in the notebook (see track ticket #16004: http://trac.sagemath.org/ticket/16004).  However, this requires an up-to-date version of jquery.  It appears that the jquery-ui-1.8.11 (about 3 years old) which we are using is not compatible.  Can somebody tell me what the theme choices were to roll an updated jquery-ui-1.10.4?


Jason Grout

unread,
Mar 25, 2014, 10:09:49 AM3/25/14
to kcrisman, sage-...@googlegroups.com
On 3/25/14, 9:02, kcrisman wrote:
>
>
> As I have posted to the sage-notebook list, I have pure javascript
> Jmol working in the notebook (see track ticket #16004:
> http://trac.sagemath.org/ticket/16004
> <http://trac.sagemath.org/ticket/16004>). However, this requires an
> up-to-date version of jquery. It appears that the jquery-ui-1.8.11
> (about 3 years old) which we are using is not compatible. Can
> somebody tell me what the theme choices were to roll an updated
> jquery-ui-1.10.4?
>
>
> I don't think it should be horrible to update, for a JS expert - for me,
> probably very horrible :)
>
> Jason, what version of Jquery-ui do you use in the cell server? Maybe
> that is a starting point for thinking about this.

1.10.2: https://github.com/sagemath/sagecell/blob/master/Makefile#L16

See
https://raw.githubusercontent.com/sagemath/sagecell/master/static/jquery-ui/js/jquery-ui-1.10.2.custom.min.js

See also
https://github.com/sagemath/sagecell/blob/master/static/jquery-ui/css/sagecell/jquery-ui-1.10.2.custom.min.css,
which points to this theme:
http://jqueryui.com/themeroller/?ffDefault=Verdana%2CArial%2Csans-serif&fwDefault=normal&fsDefault=1.1em&cornerRadius=4px&bgColorHeader=cccccc&bgTextureHeader=highlight_soft&bgImgOpacityHeader=75&borderColorHeader=aaaaaa&fcHeader=222222&iconColorHeader=222222&bgColorContent=f3f3f3&bgTextureContent=flat&bgImgOpacityContent=0&borderColorContent=dddddd&fcContent=362b36&iconColorContent=222222&bgColorDefault=99bbff&bgTextureDefault=highlight_hard&bgImgOpacityDefault=60&borderColorDefault=cccccc&fcDefault=111111&iconColorDefault=777777&bgColorHover=99bbff&bgTextureHover=highlight_hard&bgImgOpacityHover=90&borderColorHover=888888&fcHover=111111&iconColorHover=222222&bgColorActive=ffc53d&bgTextureActive=highlight_hard&bgImgOpacityActive=60&borderColorActive=a85700&fcActive=000000&iconColorActive=000000&bgColorHighlight=fbf9ee&bgTextureHighlight=glass&bgImgOpacityHighlight=55&borderColorHighlight=fcefa1&fcHighlight=363636&iconColorHighlight=2e83ff&bgColorError=fef1ec&bgTextureError=highlight
_
hard&bgImgOpacityError=95&borderColorError=cd0a0a&fcError=cd0a0a&iconColorError=cd0a0a&bgColorOverlay=aaaaaa&bgTextureOverlay=flat&bgImgOpacityOverlay=0&opacityOverlay=30&bgColorShadow=aaaaaa&bgTextureShadow=flat&bgImgOpacityShadow=0&opacityShadow=30&thicknessShadow=8px&offsetTopShadow=-8px&offsetLeftShadow=-8px&cornerRadiusShadow=8px&ctl=themeroller

Thanks,

Jason

Reply all
Reply to author
Forward
0 new messages