Maxima & ECL 10.4.1

6 views
Skip to first unread message

Juan Jose Garcia-Ripoll

unread,
Apr 4, 2010, 10:29:51 AM4/4/10
to Robert Dodier, sage-devel
ECL will introduce an incompatible change that will break building of Maxima.

The change is not gratuitous: it basically locks all functions in the core package COMMON-LISP preventing them from being redefined. This is mandated by the ANSI standard and it was just an unfortunate typo that made this lock inactive in all but a few of previous versions.

The file lisp-utils/defsystem.lisp that is shipped with Maxima assumes that this lock does not exist and it has been working so far without problems. From this version of ECL on this utility will stop working and will prevent Maxima from building.

I attach a small patch that solves this problem. This patch and the latest fixes between ECL 10.3.1 and the upcoming 10.4.1 make Maxima build without further problems. All tests pass except the one known case. I would advise upgrading Sage when the release process is finished.

I backported this patch to maxima-5.20.1 -- a diff file for that is also attached.

Juanjo

--
Instituto de Física Fundamental, CSIC
c/ Serrano, 113b, Madrid 28006 (Spain)
http://tream.dreamhosters.com
maxima-5.20.1.diff
maxima.diff

Robert Dodier

unread,
Apr 4, 2010, 4:57:02 PM4/4/10
to Juan Jose Garcia-Ripoll, sage-devel
On 4/4/10, Juan Jose Garcia-Ripoll <juanjose.g...@googlemail.com> wrote:

> ECL will introduce an incompatible change that will break building of
> Maxima.

Thanks for the patch. I've committed it to the 5.21 release branch.

best

Robert Dodier

Reply all
Reply to author
Forward
0 new messages