baikal with debian sketch

180 views
Skip to first unread message

John K

unread,
Feb 6, 2017, 8:42:49 AM2/6/17
to SabreDAV Discussion
Hi there,
is there a way to use baikal actually under debian sketch?
I use mariadb instead of mysql. I can't install php5:

# apt-get install php5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package php5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5' has no installation candidate

Thanks for any help.

mbiebl

unread,
Feb 6, 2017, 10:58:10 AM2/6/17
to SabreDAV Discussion
On Monday, February 6, 2017 at 2:42:49 PM UTC+1, John K wrote:
Hi there,
is there a way to use baikal actually under debian sketch?

I assume you mean Debian Stretch

 
I use mariadb instead of mysql. I can't install php5:

# apt-get install php5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package php5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5' has no installation candidate


This is expected. Debian Stretch only ships php7
In case you are using apache2, you probably want
libapache2-mod-php

knustj...@googlemail.com

unread,
Feb 6, 2017, 12:35:04 PM2/6/17
to sabredav...@googlegroups.com
hello,

thanks for the clear answer! :-)
Is there a nginx package too? 

thx a lot! 
& yes it's debian stretch! ;-)
--
You received this message because you are subscribed to a topic in the Google Groups "SabreDAV Discussion" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/sabredav-discuss/pXrqiKHBDLg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to sabredav-discu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sabredav-discuss/b140975f-2f08-4a6b-9a91-086f56b8eed0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

mbiebl

unread,
Feb 6, 2017, 8:21:28 PM2/6/17
to SabreDAV Discussion
On Monday, February 6, 2017 at 6:35:04 PM UTC+1, John K wrote:
hello,

thanks for the clear answer! :-)
Is there a nginx package too?

There certainly is:

But I guess you actually want to know how to get php working with nginx?
As google will tell you, the easiest way is fpm. And again, there's a Debian package:

John K

unread,
Feb 7, 2017, 3:58:44 PM2/7/17
to sabredav...@googlegroups.com
Hi everyone,

Even when my linux skills aren’t the best I want to share the information you maybe need to.
My linux Debian stretch server is now running with the actual baikal version: 0.4.6.

I use nginx so like you said I need:
apt-get install php7.0-fpm

Don’t forget to change the fastcgi_pass variable in your nginx vhost:
unix:/var/run/php/php7.0-fpm.sock;

When you check the web login and you get something like:
php-fatal-error-class-domdocument … -> this one helped me out:
apt-get install php-xml

Related to this issue you maybe want to install this too
apt-get install php-mbstring php7.0-mbstring php-gettext 

& yes there is still the macOS problem that just one address book is supported.

Last but not least in macOS and iOS you can go ahead and use the same url for calendar and contacts.
(In macOS choose manual (not automatic or advanced))


Thanks for your help!
Cheers John

--
You received this message because you are subscribed to a topic in the Google Groups "SabreDAV Discussion" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/sabredav-discuss/pXrqiKHBDLg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to sabredav-discu...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages