Encountered an issue in the final step of replacing GuestOS

36 views
Skip to first unread message

Jay Ironman

unread,
Nov 27, 2023, 11:22:37 PM11/27/23
to S2E Developer Forum
Hi:
I have reached the final step of changing GuestOS and created a snapshot using the following command:
LD_PRELOAD=/home/iie-iisd/s2e/install/share/libs2e/libs2e-x86_64.so /home/iie-iisd/s2e/install/bin/qemu-system-x86_64 -enable-kvm -drive if=ide,index=0,file=/home/iie-iisd/s2e/images/uos-v20-x86_64/image.raw.s2e,format=s2e,cache=writeback -serial file:/home/iie-iisd/s2e/images/uos-v20-x86_64/serial_ready.txt -enable-serial-commands -net none -net nic,model=e1000  -m 4096M
But after GuestOS started, it kept getting stuck in the interface shown in the following figure:
微信截图_20231128111136.png
It indicates waiting for S2E mode, but I have introduced "LD-PRELOAD=/home/iie iisd/s2e/install/share/libs2e/libs2e x86_64. so" and have successfully replaced the kernel, as shown in the following figure:
Snipaste_2023-11-28_12-13-13.png
Since I cannot find the source code for s2ecmd or bootstrap. sh, I am unable to define the cause of this issue. I hope you can give me some ideas!
Thanks.

Jay Ironman

unread,
Nov 28, 2023, 3:08:34 AM11/28/23
to S2E Developer Forum
In addition, this is the content in my "/home/s2e" directory. PS: I installed the Linux kernel separately, so there are no deb packages related to the Linux kernel in this directory, let alone I don't think they will have any impact
图片1.png

Vitaly Chipounov

unread,
Nov 28, 2023, 7:14:35 AM11/28/23
to s2e...@googlegroups.com
Hi,

You need to fix the /dev/ttyS0 permission denied issue. The script is supposed to take a snapshot and close QEMU.

Vitaly

--
You received this message because you are subscribed to the Google Groups "S2E Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to s2e-dev+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/s2e-dev/413c138e-e7e5-4883-8539-e3137d3f0498n%40googlegroups.com.

Jay Ironman

unread,
Nov 28, 2023, 8:11:15 AM11/28/23
to S2E Developer Forum
I tried it and when I used the "su" command to enter root privileges, the script was successfully executed, so GuestOS was built. However, when I used the "sudo" command, it still prompted permission issues, which must be a permission issue. However, when I checked that all the files in this directory were owned by the s2e user, why did this issue still occur? Do I have to manually enter root privileges every time I use this GuestOS?

Jay Ironman

unread,
Nov 28, 2023, 9:24:23 AM11/28/23
to S2E Developer Forum
I have solved this problem, please forgive my foolishness
Reply all
Reply to author
Forward
0 new messages