How could modify bootstrap.sh to specify symbolic parameter

29 views
Skip to first unread message

sandwich125

unread,
Nov 26, 2020, 4:19:28 AM11/26/20
to s2e...@googlegroups.com
Hi Vitaly
     I want use s2e to test "grep"
     as the command $ grep -A 1 ./test.txt, I want  symbolic the first parameter ("-A"), and the second parameter ("1"), and I do not want to symbolic the file ("./test.txt").
    in bootstap.sh I modify as following:
     S2E_SYM_ARGS="1 2" LD_PRELOAD="${S2E_SO}" "${TARGET}" -A 1  ./test.txt  > /dev/null 2 > /dev/null                 //i do not want symbolic the third parameter ("./test.txt")
     may I use the manner correctly?  because when I run it ,the result is not I want. 


 

sandwich125

unread,
Nov 30, 2020, 4:03:54 AM11/30/20
to s2e...@googlegroups.com
Hi Vitaly:
1、 some problem about unreachable path "x > y"

     I use s2e to test the following program
the program should have three path: (1) x<y &&y<z; (2) x<y&& y>z; (3) y>z.
but when I run it in s2e, it give me three path as following , there is no path x>y, but when i look its coverage, it is 100%, why s2e does not give the input "x>y", and The coverage is 100% (as following)?  or why s2e could not give the input data about path "x>y" ?



2、 
   the above test programe have three paramters, normally, symbolic the whole parameters as following:
    
 But now, I only want symbolic the first parameter and the second parameter, and fixed the third parameter as concrete value "3" in the whole process of symbolic execution on S2e running. is the following using correctly?
    


Vitaly Chipounov

unread,
Dec 2, 2020, 6:24:09 AM12/2/20
to s2e...@googlegroups.com, sandwich125

It works as expected. You are using signed integers, so 0x81 is actually negative, so 0x81 < 0.
The test case generator always prints unsigned integers.

Vitaly

--
--
You received this message because you are a member of the S2E Developer Forum.
To post to this group, send email to s2e...@googlegroups.com
To unsubscribe from this group, send email to s2e-dev+u...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/s2e-dev

---
You received this message because you are subscribed to the Google Groups "S2E Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to s2e-dev+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/s2e-dev/36d918ab.50ce.1761864038a.Coremail.sandwich125%40126.com.
Reply all
Reply to author
Forward
Message has been deleted
0 new messages