execution failed on x nodes

60 views
Skip to first unread message

Jeremy

unread,
Mar 2, 2011, 4:07:15 AM3/2/11
to rundeck-discuss
Hi,

I have run rundeck for a couple of days now, and I get this error on a
few nodes. I read that osFamily should not be null, and other stuff
like that, but so far, I haven't been able to run a single command on
that node.

My nodes are configured :
<node name="server34-user07" type="Node" description="Rundeck server
node" tags="" hostname="server34" osArch="" osFamily="unix"
osName="AIX" osVersion="" username="user07" editUrl="" remoteUrl=""/>
<node name="server48-user60" type="Node" description="Rundeck server
node" tags="" hostname="server48" osArch="" osFamily="unix"
osName="AIX" osVersion="" username="user60" editUrl="" remoteUrl=""/>

server34 runs perfectly, while I can't run anything on server60. The
two servers are on same OS (AIX 5.3TL10).

Message I get in IHM is "Execution failed on the following 1 nodes:
[server48-user60]". I can't find more info in the logs ...

So, while I was writing this email, I found the answer (always helps
to try to explain the problem to someone else :-) : change the
authorized_keys file of the server60 to use the dsa key instead of the
rsa key of the rundeck server (the rundeck server has the two keys
generated). However, I read in the documentation [1] that "By default,
the RunDeck installation is configured to use RSA not DSA type keys
(however, it can be configured to use DSA, if required).".

I send this email, in case it may help someone else or you have any
comment on this, never know.

Regards (and thanks for this noce piece of software !),

Jérémy
[1] http://rundeck.org/docs/RunDeck-Guide.html#ssh-key-generation
Reply all
Reply to author
Forward
0 new messages