Sqlite3 seg faulting in rvm 1.9.2 head

30 views
Skip to first unread message

AGoofin

unread,
Jun 4, 2010, 5:26:20 PM6/4/10
to rvm (Ruby Version Manager)
I'm trying to load rails 3.0 beta in rvm using ruby 1.9.2-head, which
according to several web pages should be able to be setup for rails
3.0.

Sqlite3 is segfaulting in rake though:
brian@juvy-re-tread:~/rails/test_proj$ rake db:create
(in /home/brian/rails/test_proj)
/home/brian/.rvm/gems/ruby-1.9.2-head/gems/sqlite3-ruby-1.3.0.beta.2/
lib/sqlite3/sqlite3_native.so: [BUG] Segmentation fault
ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-linux]

Weird though is that if I dont do the rake task, rails does
communicate with sqlite3 to see that there is no table. I'm wondering
about the reference to ruby-1.8.7-174 as well - system is 1.8.7-249

Here's my rvm info:
brian@juvy-re-tread:~/rails/test_proj$ rvm info
ruby-1.9.2-head:

system:
uname: "Linux juvy-re-tread 2.6.32-22-generic #35-Ubuntu
SMP Tue Jun 1 14:17:36 UTC 2010 i686 GNU/Linux"
shell: "bash"
version: "4.1.5(1)-release"

rvm:
type: "rvm is /home/brian/.rvm/bin/rvm"
version: "rvm 0.1.38 by Wayne E. Seguin
(waynee...@gmail.com) [http://rvm.beginrescueend.com/]"

ruby:
interpreter: "ruby"
version: "1.9.2dev"
date: "2010-06-04"
platform: "i686-linux"
patchlevel: "2010-06-04 revision 28156"
full_version: "ruby 1.9.2dev (2010-06-04 revision 28156) [i686-
linux]"

homes:
gem: "/home/brian/.rvm/gems/ruby-1.9.2-head"
ruby: "/home/brian/.rvm/rubies/ruby-1.9.2-head"

binaries:
ruby: "/home/brian/.rvm/rubies/ruby-1.9.2-head/bin/ruby"
irb: "/home/brian/.rvm/rubies/ruby-1.9.2-head/bin/irb"
gem: "/home/brian/.rvm/rubies/ruby-1.9.2-head/bin/gem"
rake: "/home/brian/.rvm/gems/ruby-1.9.2-head/bin/rake"

environment:
GEM_HOME: "/home/brian/.rvm/gems/ruby-1.9.2-head"
GEM_PATH: "/home/brian/.rvm/gems/ruby-1.9.2-head:/home/
brian/.rvm/gems/ruby-1.9.2-head@global"
BUNDLE_PATH: "/home/brian/.rvm/gems/ruby-1.9.2-head"
MY_RUBY_HOME: "/home/brian/.rvm/rubies/ruby-1.9.2-head"
IRBRC: "/home/brian/.rvm/rubies/ruby-1.9.2-head/.irbrc"
RUBYOPT: ""
gemset: ""

I also just updated rvm as well but this was happening previously.

Wayne E. Seguin

unread,
Jun 4, 2010, 7:17:28 PM6/4/10
to rubyversi...@googlegroups.com
Not enough information to say anything really.

My guess would be that the shebang line of the rake / binary is set
somehow to 1.8.7.

~Wayne

AGoofin

unread,
Jun 5, 2010, 9:17:47 AM6/5/10
to rvm (Ruby Version Manager)
If I use:

rvm 1.9.2-head rake db:migrate

It works just fine.

I'll check the shebang line though.


Wonderful project though, thank you Wayne.

Wayne E. Seguin

unread,
Jun 5, 2010, 7:40:50 PM6/5/10
to rubyversi...@googlegroups.com
On Sat, Jun 5, 2010 at 9:17 AM, AGoofin <amo...@gmail.com> wrote:
> If I use:
>
> rvm 1.9.2-head rake db:migrate
>
> It works just fine.
>
> I'll check the shebang line though.
>
>
> Wonderful project though, thank you Wayne.

Very glad that you are finding it useful :)

Reply all
Reply to author
Forward
0 new messages