Ruby a problém s SQlite3

12 views
Skip to first unread message

Robin BlueJ

unread,
Jul 27, 2021, 3:58:58 PMJul 27
to rubyon...@googlegroups.com
Dobrý den,

začínám s Ruby, mám Windows 8 a prosím o pomoc.
Nedokážu se dostat ani za New Blog. Myslela jsem si, že je problém se sqlite3, že tu cestu systém nedokáže najít (je nainstalovaný, konkrétně verze 3.36.0) . Prošla jsem různé anglické návody. A zatím nic... Prosím, můžete se:
1. podívat, že je skutečně problém jen s cestou k sqlite3
2. poradit blbuvzdorně, co s tím?

Níže přikládám popis z příkazového řádku.
Moc děkuji 

Fetching sqlite3 1.4.2
Installing sqlite3 1.4.2 with native extensions
chyba: GPGME error: Invalid crypto engine
chyba: mingw32: chýba vyžadovaný podpis
chyba: GPGME error: Invalid crypto engine
chyba: mingw64: chýba vyžadovaný podpis
chyba: GPGME error: Invalid crypto engine
chyba: ucrt64: chýba vyžadovaný podpis
chyba: GPGME error: Invalid crypto engine
chyba: clang64: chýba vyžadovaný podpis
chyba: GPGME error: Invalid crypto engine
chyba: msys: chýba vyžadovaný podpis
chyba: databáza 'mingw32' nie je platná (neplatná alebo poškodená databáza (PGP
podpis))
chyba: databáza 'mingw64' nie je platná (neplatná alebo poškodená databáza (PGP
podpis))
chyba: databáza 'ucrt64' nie je platná (neplatná alebo poškodená databáza (PGP p
odpis))
chyba: databáza 'clang64' nie je platná (neplatná alebo poškodená databáza (PGP
podpis))
chyba: databáza 'msys' nie je platná (neplatná alebo poškodená databáza (PGP pod
pis))
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/sqlite3-1.4.2/ext/sqlite3
C:/Ruby27-x64/bin/ruby.exe -I C:/Ruby27-x64/lib/ruby/2.7.0 -r
./siteconf20210727-6908-od6azc.rb extconf.rb
checking for sqlite3.h... no
sqlite3.h is missing. Install SQLite3 from http://www.sqlite.org/ first.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby27-x64/bin/$(RUBY_BASE_NAME)
        --with-sqlcipher
        --without-sqlcipher
        --with-sqlite3-config
        --without-sqlite3-config
        --with-pkg-config
        --without-pkg-config
        --with-sqlcipher
        --without-sqlcipher
        --with-sqlite3-dir
        --without-sqlite3-dir
        --with-sqlite3-include
        --without-sqlite3-include=${sqlite3-dir}/include
        --with-sqlite3-lib
        --without-sqlite3-lib=${sqlite3-dir}/lib

To see why this extension failed to compile, please check the mkmf.log which can

be found here:

C:/Ruby27-x64/lib/ruby/gems/2.7.0/extensions/x64-mingw32/2.7.0/sqlite3-1.4.2/mkm
f.log

extconf failed, exit code 1

Gem files will remain installed in
C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/sqlite3-1.4.2 for inspection.
Results logged to
C:/Ruby27-x64/lib/ruby/gems/2.7.0/extensions/x64-mingw32/2.7.0/sqlite3-1.4.2/gem
_make.out

An error occurred while installing sqlite3 (1.4.2), and Bundler cannot continue.

Make sure that `gem install sqlite3 -v '1.4.2' --source 'https://rubygems.org/'`

succeeds before bundling.

In Gemfile:
  sqlite3
         run  bundle binstubs bundler
Could not find gem 'sqlite3 (~> 1.4) x64-mingw32' in any of the gem sources
listed in your Gemfile.
       rails  webpacker:install
Could not find gem 'sqlite3 (~> 1.4) x64-mingw32' in any of the gem sources list
ed in your Gemfile.
Run `bundle install` to install missing gems.

Bez virů. www.avast.com

Robin Bortlik

unread,
Jul 29, 2021, 5:22:08 AMJul 29
to rubyon...@googlegroups.com
Dobrý den, 

nemám windows a proto nemám moc tušení kde je chyba, ale hádal bych stejně jako vy, že je to v cestě k sqlite3, tak jak píšete. 
Napadají mě 2 možnosti:
- 1) zkusit použít jinou knihovnu jako autor tohoto videa: https://www.youtube.com/watch?v=cAseoJeNG8I
- 2) zkusit ten gem instalovat nejprve lokalne s parametry pro cestku k sqlite3. Ten příkaz by měl vypadat asi takto: 
  gem install sqlite3 --platform=ruby -- --with-sqlite3-include=/c:/dev/sqlite3/ --with-sqlite3-lib=/c:/dev/sqlite3/.libs/


Dejte vědět jestli pomohlo. 

--
Tuto zprávu jste obdrželi, protože jste přihlášeni k odběru skupiny „rubyonrails.cz“ ve Skupinách Google.
Chcete-li zrušit odběr skupiny a přestat dostávat e‑maily ze skupiny, zašlete e-mail na adresu rubyonrailsc...@googlegroups.com.
Chcete-li tuto diskusi zobrazit na webu, navštivte https://groups.google.com/d/msgid/rubyonrailscz/CALjqKjcr44Ma0mPf88M1v3T7kOeUEq3Q82%2B0nnUcoB4kJqROjQ%40mail.gmail.com.


--
Reply all
Reply to author
Forward
0 new messages