I cannot run rails -v

31 views
Skip to first unread message

Jamal Soueidan

unread,
Dec 20, 2007, 3:21:36 AM12/20/07
to rubyonra...@googlegroups.com
Hi,

After I update rails I cannot run rails -v anymore?

sudo gem update rails
Password:
Updating installed gems...
Bulk updating Gem source index for: http://gems.rubyforge.org
Attempting remote update of rails
Successfully installed rails-2.0.2
1 gem installed
Gems: [rails] updated
Jamal:videosite $ rails -v
/Library/Ruby/Site/1.8/rubygems.rb:377:in `report_activate_error':
RubyGem version error: activesupport(1.4.2 not = 2.0.2) (Gem::LoadError)
from /Library/Ruby/Site/1.8/rubygems.rb:309:in `activate'
from /Library/Ruby/Site/1.8/rubygems.rb:335:in `activate'
from /Library/Ruby/Site/1.8/rubygems.rb:334:in `each'
from /Library/Ruby/Site/1.8/rubygems.rb:334:in `activate'
from /Library/Ruby/Site/1.8/rubygems.rb:76:in
`active_gem_with_options'
from /Library/Ruby/Site/1.8/rubygems.rb:50:in `gem'
from /Library/Ruby/bin/rails:15

------------------------------

Do I miss something?

I tried with gem install rails --include-dependencies but this installed
rails 2.0.2 once again?

Thanks for any help :)
--
Posted via http://www.ruby-forum.com/.

Jochen Kaechelin

unread,
Dec 20, 2007, 3:55:07 AM12/20/07
to rubyonra...@googlegroups.com

You are running a wrong version of activesupport (RubyGem version
error: activesupport(1.4.2 not = 2.0.2) (Gem::LoadError))

Have you tried "gem install activesupport" ?

Jamal Soueidan

unread,
Dec 20, 2007, 4:01:54 AM12/20/07
to rubyonra...@googlegroups.com
Jochen Kaechelin wrote:
> Am 20.12.2007 um 09:21 schrieb Jamal Soueidan:
>
>> Successfully installed rails-2.0.2
>> from /Library/Ruby/Site/1.8/rubygems.rb:76:in

>> rails 2.0.2 once again?
> You are running a wrong version of activesupport (RubyGem version
> error: activesupport(1.4.2 not = 2.0.2) (Gem::LoadError))
>
> Have you tried "gem install activesupport" ?

*** LOCAL GEMS ***

actionmailer (1.3.5, 1.3.3)
actionpack (1.13.5, 1.13.3)
actionwebservice (1.2.5, 1.2.3)
activerecord (1.15.5, 1.15.3)
activesupport (1.4.4, 1.4.2)


I have those installed already, do I need to update them?

Jochen Kaechelin

unread,
Dec 20, 2007, 4:10:38 AM12/20/07
to rubyonra...@googlegroups.com

I should look like this:

actionmailer (2.0.2)
actionpack (2.0.2)
actionwebservice (1.2.6)
activerecord (2.0.2)
activeresource (2.0.2)
activesupport (2.0.2)

Try this:

gem update --system
gem update --source http://gems.rubyonrails.org


--
Jochen Kaechelin
figgfrosch.de / gissmoh.de / ror-ror.de / railswerk.de


Jamal Soueidan

unread,
Dec 20, 2007, 6:41:48 AM12/20/07
to rubyonra...@googlegroups.com
I just did that Jochen Kaechelin :)

#sudo gem update --system
Password:
Updating RubyGems...
Updating metadata for 7 gems from http://gems.rubyforge.org
.......
complete
Attempting remote update of rubygems-update
Successfully installed rubygems-update-1.0.0
1 gem installed
Updating version of RubyGems to 1.0.0
Installing RubyGems 1.0.0

.........

cp update_rubygems /tmp/update_rubygems
install -c -m 0755 /tmp/update_rubygems
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/update_rubygems
rm /tmp/update_rubygems
rm /Library/Ruby/Gems/1.8/source_cache
Removing old RubyGems RDoc and ri...
rm -rf /Library/Ruby/Gems/1.8/doc/rubygems-0.9.5
Installing rubygems-1.0.0 ri into
/Library/Ruby/Gems/1.8/doc/rubygems-1.0.0/ri...
Installing rubygems-1.0.0 rdoc into
/Library/Ruby/Gems/1.8/doc/rubygems-1.0.0/rdoc...
As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a
while)...
...done.
No library stubs found.
RubyGems system software updated

#sudo gem update --source http://gems.rubyonrails.org
Updating installed gems...
Bulk updating Gem source index for: http://gems.rubyonrails.org
Attempting remote update of actionmailer
Successfully installed actionmailer-2.0.2
1 gem installed
Installing ri documentation for actionmailer-2.0.2...
Installing RDoc documentation for actionmailer-2.0.2...
Attempting remote update of actionpack
Successfully installed actionpack-2.0.2
1 gem installed
Installing ri documentation for actionpack-2.0.2...
ERROR: While generating documentation for actionpack-2.0.2
... MESSAGE: Unhandled special: Special: type=33, text="TODO"
... RDOC args: --ri --op /Library/Ruby/Gems/1.8/doc/actionpack-2.0.2/ri
--quiet lib
(continuing with the rest of the installation)
Installing RDoc documentation for actionpack-2.0.2...
Attempting remote update of activerecord
Successfully installed activerecord-2.0.2
1 gem installed
Installing ri documentation for activerecord-2.0.2...
ERROR: While generating documentation for activerecord-2.0.2
... MESSAGE: Unhandled special: Special: type=33, text="Id"
... RDOC args: --ri --op
/Library/Ruby/Gems/1.8/doc/activerecord-2.0.2/ri --main README --quiet
lib README
(continuing with the rest of the installation)
Installing RDoc documentation for activerecord-2.0.2...
Attempting remote update of activesupport
Successfully installed activesupport-2.0.2
1 gem installed
Installing ri documentation for activesupport-2.0.2...
ERROR: While generating documentation for activesupport-2.0.2
... MESSAGE: Unhandled special: Special: type=33, text="Ruby"
... RDOC args: --ri --op
/Library/Ruby/Gems/1.8/doc/activesupport-2.0.2/ri --quiet lib
(continuing with the rest of the installation)
Installing RDoc documentation for activesupport-2.0.2...
Gems updated: actionmailer, actionpack, activerecord, activesupport


I still get error when I run rails -v

rails -v
/Library/Ruby/Site/1.8/rubygems.rb:378:in `report_activate_error': Could
not find RubyGem activeresource (= 2.0.2) (Gem::LoadError)
from /Library/Ruby/Site/1.8/rubygems.rb:310:in `activate'
from /Library/Ruby/Site/1.8/rubygems.rb:336:in `activate'
from /Library/Ruby/Site/1.8/rubygems.rb:335:in `each'


from /Library/Ruby/Site/1.8/rubygems.rb:335:in `activate'

from /Library/Ruby/Site/1.8/rubygems.rb:65:in

`active_gem_with_options'
from /Library/Ruby/Site/1.8/rubygems.rb:50:in `gem'
from /Library/Ruby/bin/rails:15


:(

Jamal Soueidan

unread,
Dec 20, 2007, 6:42:45 AM12/20/07
to rubyonra...@googlegroups.com
This is the new gem list

actionmailer (2.0.2, 1.3.5, 1.3.3)
actionpack (2.0.2, 1.13.5, 1.13.3)
actionwebservice (1.2.5, 1.2.3)
activerecord (2.0.2, 1.15.5, 1.15.3)
activesupport (2.0.2, 1.4.4, 1.4.2)

Jochen Kaechelin

unread,
Dec 20, 2007, 7:32:13 AM12/20/07
to rubyonra...@googlegroups.com

Am 20.12.2007 um 12:41 schrieb Jamal Soueidan:
>
> I still get error when I run rails -v
>
> rails -v
> /Library/Ruby/Site/1.8/rubygems.rb:378:in `report_activate_error':
> Could
> not find RubyGem activeresource (= 2.0.2) (Gem::LoadError)
> from /Library/Ruby/Site/1.8/rubygems.rb:310:in `activate'
> from /Library/Ruby/Site/1.8/rubygems.rb:336:in `activate'
> from /Library/Ruby/Site/1.8/rubygems.rb:335:in `each'
> from /Library/Ruby/Site/1.8/rubygems.rb:335:in `activate'
> from /Library/Ruby/Site/1.8/rubygems.rb:65:in
> `active_gem_with_options'
> from /Library/Ruby/Site/1.8/rubygems.rb:50:in `gem'
> from /Library/Ruby/bin/rails:15

try

gem install activeresource --source http://gems.rubyonrails.org


--
Jochen

Jamal Soueidan

unread,
Dec 20, 2007, 11:32:16 AM12/20/07
to rubyonra...@googlegroups.com

Thank you very much :)

German Gomez

unread,
Jun 28, 2008, 7:00:45 PM6/28/08
to rubyonra...@googlegroups.com

I'm having the same problem but i get: Error installing activeresource:
invalid gem format for
/Library/Ruby/Gems/1.8/cache/activesupport-2.1.0.gem
when i try to install active support.

Reply all
Reply to author
Forward
0 new messages