I'm having trouble installing jekyll by ruby 2.6.5

18 views
Skip to first unread message

谢小宝

unread,
Mar 22, 2020, 8:11:59 AM3/22/20
to RubyInstaller
Temporarily enhancing PATH for MSYS/MINGW...
Building native extensions. This could take a while...
ERROR:  Error installing jekyll:
        ERROR: Failed to build gem native extension.

    current directory: D:/Ruby26-x64/lib/ruby/gems/2.6.0/gems/http_parser.rb-0.6.0/ext/ruby_http_parser
D:/Ruby26-x64/bin/ruby.exe -I D:/Ruby26-x64/lib/ruby/site_ruby/2.6.0 -r ./siteconf20200322-2892-1sv8h9.rb extconf.rb
creating Makefile

current directory: D:/Ruby26-x64/lib/ruby/gems/2.6.0/gems/http_parser.rb-0.6.0/ext/ruby_http_parser
make "DESTDIR=" clean
current directory: D:/Ruby26-x64/lib/ruby/gems/2.6.0/gems/http_parser.rb-0.6.0/ext/ruby_http_parser
make "DESTDIR="
make failedNo such file or directory - make "DESTDIR="

Gem files will remain installed in D:/Ruby26-x64/lib/ruby/gems/2.6.0/gems/http_parser.rb-0.6.0 for inspection.
Results logged to D:/Ruby26-x64/lib/ruby/gems/2.6.0/extensions/x64-mingw32/2.6.0/http_parser.rb-0.6.0/gem_make.out
Reply all
Reply to author
Forward
0 new messages