The ipv6 issue of rubygems.org should be fixed.

68 views
Skip to first unread message

Kisaragi Wong

unread,
Jun 8, 2020, 3:44:13 PM6/8/20
to rubygems.org
Hello, when I was installing bundler on my VM, I was troubled by "Could not find a valid gem 'bundler' (>= 0), here is why:         Unable to download data from https://rubygems.org/ - timed out (https://rubygems.org/specs.4.8.gz)"

I did find some quick fix like this one " https://help.rubygems.org/discussions/problems/33671-suggestion-for-easy-solution-for-the-ipv6-related-timeout-problem " and this one " https://stackoverflow.com/questions/49800432/gem-cannot-access-rubygems-org ". It worked, but I guess this issue fixed because it's been years and it's quite weird and troublesome.  :( 

Michael Richardson

unread,
Oct 8, 2020, 1:49:58 PM10/8/20
to rubygems.org
I also had the IPv6 issue again.  Clearly the status panel lies: it should be orange or yellow if IPv6 is broken.
Many of us report this.  Many of us with deep IPv6 knowledge and experience report the problem.

Please just remove the AAAA until it is resolved.  
Email unicast me if you can, and please CC your hosting provider, and we solve this.

Aditya Prakash

unread,
Oct 8, 2020, 3:33:17 PM10/8/20
to rubyge...@googlegroups.com
Hi Michael,

Thank you for reaching out. I agree this IPv6 issue is very frustrating and impacts multiple users. I have created a Fastly support ticket with this issue and have been looking for users who can provide legit debugging info I can forward to the Fastly support team. I have reached out on multiple threads[1][2][3][4][5] and on all of them either the issue was in the client's network (IPv6 route was misconfigured on user's network) or I received no response.
I seem to have missed this thread. Can you please confirm that you are not able to access sites hosted only on Fastly or any IPv6 site:

$ wget -6 www.rubygems.org # most likely fails for you
$ wget -6 www.google.com # will work. if this fails as well, check your ipv6 routes.
If you have access to a host where only sites hosted on Fastly don't work, you are the one I have been looking for. You can create a support ticket to debug this further by sending a mail to sup...@rubygems.org or we can continue in this public thread. 

I am also trying to implement a client-side fix for this[6], if you want to see that get release please give that thread a bump or better yet test the patch on your host and confirm that it fixes your issue.

[1] https://help.rubygems.org/discussions/problems/31074-timeout-error#comment_48575318
[2] https://help.rubygems.org/discussions/problems/35757-rubygems-access-via-ipv6#comment_48575307
[3] https://github.com/rubygems/rubygems/issues/2253#issuecomment-687747681
[4] https://help.rubygems.org/discussions/problems/34938-ipv6-still-broken-in-2019-please-delete-your-aaaa-records-until-it-can-be-resolved#comment_48459667
[5] https://github.com/rubygems/rubygems/issues/3641#issuecomment-687752740
[6] https://github.com/rubygems/rubygems/pull/2662



--
You received this message because you are subscribed to the Google Groups "rubygems.org" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubygems-org...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubygems-org/05663d57-75b1-4eb3-a2ab-0e20ab016d5fn%40googlegroups.com.

Michael Richardson

unread,
Oct 9, 2020, 1:30:27 PM10/9/20
to rubyge...@googlegroups.com

Aditya Prakash <aditya.p...@gmail.com> wrote:
> $ wget -6 www.rubygems.org # most likely fails for you
> $ wget -6 www.google.com # will work. if this fails as well, check
> your ipv6 routes.

Today, both work.
Yesterday, after some debugging, I reached out to my ISP, and found that
there a route filter that was fixed.

I don't have details yet, and I might get them.
We need gem to try all addresses.

--
] Never tell me the odds! | ipv6 mesh networks [
] Michael Richardson, Sandelman Software Works | IoT architect [
] m...@sandelman.ca http://www.sandelman.ca/ | ruby on rails [

signature.asc

Aditya Prakash

unread,
Oct 10, 2020, 5:23:38 AM10/10/20
to rubyge...@googlegroups.com
Good to hear it worked out for you. It is kinda shitty that ruby doesn't support IPv4 fallback, most HTTP clients, and modern programming languages do. Perhaps not verifying this was an oversight on our part. Otherwise, rest assured that rubygems.org IPv6 is correctly configured and should be reachable from all IPv6 networks.
Please feel free to reach out through our support email if the issue comes up again.

--
You received this message because you are subscribed to the Google Groups "rubygems.org" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubygems-org...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages