Problem: Rake Test -- rake aborted! activated rake 10.1.0

624 views
Skip to first unread message

Robert Jewell

unread,
Sep 25, 2013, 12:06:47 PM9/25/13
to ruby-...@googlegroups.com
Hi All, 

Two questions, 

First question: is the gem, gem 'faker', or , gem 'faker', '1.1.2'?

Second question: After installing the gem, gem 'faker', '1.1.2', into my gem file, I ran, rake test, and received the following:

$ rake test
rake aborted!
You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.3. Using bundle exec may solve this.
/usr/local/rvm/gems/ruby-1.9.3-p448@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:33:in `block in setup'
/usr/local/rvm/gems/ruby-1.9.3-p448@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:19:in `setup'
/usr/local/rvm/gems/ruby-1.9.3-p448@global/gems/bundler-1.3.5/lib/bundler.rb:120:in `setup'
/usr/local/rvm/gems/ruby-1.9.3-p448@global/gems/bundler-1.3.5/lib/bundler/setup.rb:7:in `<top (required)>'
/Users/robertjewell/code/omrails/config/boot.rb:6:in `<top (required)>'
/Users/robertjewell/code/omrails/config/application.rb:1:in `<top (required)>'
/Users/robertjewell/code/omrails/Rakefile:5:in `<top (required)>'
/usr/local/rvm/gems/ruby-1.9.3-p448/bin/ruby_executable_hooks:14:in `eval'
/usr/local/rvm/gems/ruby-1.9.3-p448/bin/ruby_executable_hooks:14:in `<main>'
(See full trace by running task with --trace)

Does anyone know what's going on? When I head this advice and try : to > gem uninstall rake> # pick version 10.1.0 from the offered choices. version 10.1.0 is not an available option. I see the following when I do $ gem uninstall rake:

$ gem uninstall rake

Select gem to uninstall:
 1. rake-0.9.2.2
 2. rake-10.0.3
 3. All versions
So, the command line is telling me that, You have already activated rake 10.1.0. But when I go to run, $ gem uninstall rake, it doesn't show me the possibility of removing, rake-10.1.0

I'm just lost here. Does anyone know why, $ rake test, is running into problems? Does anyone have any suggestions?

Louise Rains

unread,
Sep 25, 2013, 1:00:38 PM9/25/13
to ruby-...@googlegroups.com
You can try the suggestion from the error message:

You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.3. Using bundle exec may solve this.

Try using
bundle exec rake test


Reply all
Reply to author
Forward
0 new messages