Bundle install hanging

210 views
Skip to first unread message

Chad Woolley

unread,
Oct 8, 2016, 8:39:41 PM10/8/16
to Bundler
When I run `DEBUG_RESOLVER=y bundle install --verbose`, it is always hanging on the following:

...
Looking up gems ["celluloid-gems", "faraday-middleware"]
Fetching dependency metadata from https://rubygems.org/
Looking up gems ["celluloid-gems", "faraday-middleware"]


What I've found:
* There's no reference to 'celluloid' at all in the project's Gemfile/.lock, and only 'faraday' is referenced in the Gemfile.lock.
* 'celluloid-gems' does not exist on rubygems.org (but is referenced by https://rubygems.org/gems/celluloid-essentials/versions/0.20.0.pre12, which again is not referenced anywhere in my project)
* 'faraday-middleware' (with dash) does not exist on rubygems.org, but 'faraday_middleware' (underscore) does.  But again, neither of these is referenced in Gemfile.lock, only 'faraday'.

I did find this ticket referencing recent SSL cert issues: https://groups.google.com/forum/#!msg/rubygems-org/jcqpXXvOo0c/QC2KZUJvAQAJ - which looked promising and led me to make sure I was on latest rubygems, but that didn't help.

Also, http://help.rubygems.org/ open ticket bucket is broken, so can't report there (if it's a rubygems.org problem).

Any tips on how to further debug, or even if this is a bundler or a rubygems.org problem?

Versions:
Ruby 2.3.1 via RVM on OSX
Gem version 2.6.7 (latest)
Bundler version 1.31.2 (latest)

Thanks,
-- Chad

Chad Woolley

unread,
Oct 10, 2016, 1:16:09 PM10/10/16
to Bundler
So, just to follow up - I fixed this, and it appears to have only been a problem on one machine.

This Gemfile would always hang:


gem "rails-controller-testing", :git => "https://github.com/rails/rails-controller-testing"

When I removed the ":git" directive, and just let it pull the latest version of the Gem, no more hanging.

No idea why or what the root cause, still happened even if I deleted all bundler git cache and all references to the gem in the RVM tree and tried again.
.
Thanks,
-- Chad

Reply all
Reply to author
Forward
0 new messages