Bam file created, but no alignable.fq.

Skip to first unread message

Zhuyi Xue

Jun 24, 2014, 1:58:48 PM6/24/14
Hi there,

What could be the reason why no alignable_1.fq is generated and all reads are written to GSM1272882_un_1.fq and GSM1272882_un_2.fq?

Here is the stderr,

[samopen] SAM header is present: 93312 sequences.
# reads processed: 8792495
# reads with at least one reported alignment: 0 (0.00%)
# reads that failed to align: 8792495 (100.00%)
No alignments
Cannot open GSM1272882.temp/GSM1272882_alignable_1.fq! It may not exist.

and here is the log for stdout:

bowtie -q --phred33-quals -n 2 -e 99999999 -l 25 -I 1 -X 1000 --chunkmbs 256 -p 4 -a -m 200 -S mm10_ensembl_72 -1 /dev/fd/63 -2 /dev/fd/62 | samtools view -S -b -o GSM1272882.temp/GSM1272882.bam -

./rsem-1.2.5/rsem-parse-alignments mm10_ensembl_72 GSM1272882.temp/GSM1272882 GSM1272882.stat/GSM1272882 b GSM1272882.temp/GSM1272882.bam -t 3 -tag XM
Parsed 1000000 entries
Parsed 2000000 entries
Parsed 3000000 entries
Parsed 4000000 entries
Parsed 5000000 entries
Parsed 6000000 entries
Parsed 7000000 entries
Parsed 8000000 entries

./rsem-1.2.5/rsem-build-read-index 32 1 0 GSM1272882.temp/GSM1272882_alignable_1.fq GSM1272882.temp/GSM1272882_alignable_2.fq
"./rsem-1.2.5/rsem-build-read-index 32 1 0 GSM1272882.temp/GSM1272882_alignable_1.fq GSM1272882.temp/GSM1272882_alignable_2.fq" failed! Plase check if you provide correct parameters/options for the pipeline!


Summer Rae

Dec 8, 2014, 5:10:20 PM12/8/14
I'm getting the same error.. did you ever get any help on this? 

Bo Li

Dec 9, 2014, 2:43:14 PM12/9/14
Hi Summer,

The error message suggested that you set '--paired-end' option for an
single-end data set.

> --
> RSEM website: [1]
> ---
> You received this message because you are subscribed to the Google
> Groups "RSEM Users" group.
> To unsubscribe from this group and stop receiving emails from it,
> send an email to
> To post to this group, send email to
> Visit this group at [2].
> Links:
> ------
> [1]
> [2]

Abhishek Ajay

Mar 30, 2023, 5:59:42 PM3/30/23
to RSEM Users
Hi! I am getting the same error. You mention that the error message suggests that it's a single end data set but 
  1. the original post has paired end data as inputs 
  2. my dataset is paired end reads as well. 
    1. I am running RSEM on multiple samples with paired-end reads and one of the sample is giving me the same error: 
rsem-build-read-index 32 1 0 AA3_KP1_Neo_3.temp/AA3_KP1_Neo_3_alignable_1.fq AA3_KP1_Neo_3.temp/AA3_KP1_Neo_3_alignable_2.fq 
Cannot open AA3_KP1_Neo_3.temp/AA3_KP1_Neo_3_alignable_1.fq! It may not exist. 
"rsem-build-read-index 32 1 0 AA3_KP1_Neo_3.temp/AA3_KP1_Neo_3_alignable_1.fq AA3_KP1_Neo_3.temp/AA3_KP1_Neo_3_alignable_2.fq" failed! Plase check if you provide correct parameters/options for the pipeline!

Will highly appreciate your input on this. Thanks! 
Reply all
Reply to author
0 new messages