rsem-run-em FAILED (-p / threads error) v1.3.0

Skip to first unread message

May 26, 2018, 12:07:31 PM5/26/18
to RSEM Users
Running rsem/1.3.0

I'm feeding in BAM files from STAR's --quantMode (following alternate protocol 7)

STAR --genomeDir ~/STAR-index/ \
--readFilesIn ~/Sample1_R1_001_Qtrim.fq \
~/Sample1_R2_001_Qtrim.fq \
--sjdbGTFfile ~/myref.GTF \
--sjdbOverhang 149 --quantMode TranscriptomeSAM \
--outFileNamePrefix ~/Sample1_STAR \

And have prepared a RSEM reference

rsem-prepare-reference --gtf ~/myref.GTF \

And have tried running rsem

rsem-calculate-expression --no-bam-output --paired-end --strandedness reverse --alignments \
~/Sample1_Aligned.toTranscriptome.out.bam \
~/ref/myref_rsem \
~/rsem/Quant \

but it error's out at the rsem-run-em step, and I think it's an error with assigning threads (-p)
EM_init finished! \
estimateFromReads, N1 finished. \
"rsem-run-em ~/ref/myref_rsem 3 \
~/rsem/Quant \
~/rsem/Quant.temp \
~/rsem/Quant.stat -p 12" 
failed! Plase check if you provide correct parameters/options for the pipeline!

I've tried removing the -p option to no avail.  Not sure what's wrong. Please advise!! 

PS: I'm running this on a server with the header below provided:
#SBATCH -n 12
#SBATCH --mem=60G
#SBATCH -t 1:00:00
#SBATCH -o ~/jobs/RSEM_quantSTAR_%j.out
#SBATCH -e ~/jobs/RSEM_quantSTAR_%j.err
#SBATCH --mail-type=FAIL

though, I've also tried removing the #SBATCH -n 12 option, just in case there was a conflict with rsem's -p specification.


Khadija Wilson

May 5, 2021, 1:22:21 PM5/5/21
to RSEM Users

Hi, were you able to fix this?
Reply all
Reply to author
0 new messages