openflow.discovery:link detected: ; WARNING:openflow.of_01:<class 'pox.openflow.PacketIn'> raised on dummy OpenFlow nexus ; openflow.discovery:link timeout: pingall 100% dropped

234 views
Skip to first unread message

me

unread,
Mar 18, 2016, 1:24:05 AM3/18/16
to RouteFlow
Hi RouteFlow Group.

I have already made custom topology (7 switches and 5 hosts), in OSPF,
but i've been failed to pingall (use script edited from rftest2-script), it's 100% dropped.

i don't know what should i do to make it works, may be you guys can help me to solve this problem.

I've analyzed the output from my rftest4 file (run sudo ./rftest4) and also in my topology in mininet.

I found something strange in my output, but it's just my feeling...... These are a few parts:
....
INFO:openflow.of_01:[00-00-00-00-00-06 9] connected
INFO:openflow.topology:Switch 00-00-00-00-00-06 connected
....
INFO:openflow.discovery:link detected: 00-00-00-00-00-02.3 -> 00-00-00-00-00-06.2
....
WARNING:openflow.of_01:<class 'pox.openflow.PacketIn'> raised on dummy OpenFlow nexus
....
INFO:rfproxy:routemod sent to datapath (dp_id=0x7)
INFO:openflow.discovery:link detected: 00-00-00-00-00-03.2 -> 00-00-00-00-00-07.2
....
INFO:openflow.discovery:link timeout: 00-00-00-00-00-02.3 -> 00-00-00-00-00-06.2
INFO:openflow.discovery:link timeout: 00-00-00-00-00-03.2 -> 00-00-00-00-00-07.2




*** Creating network
*** Adding controller
*** Adding hosts:
h1 h2 h3 h4 h5 
*** Adding switches:
s1 s2 s3 s4 s5 s6 s7 
*** Adding links:
(h1, s1) (h2, s2) (h3, s3) (h4, s4) (h5, s5) (s1, s2) (s1, s6) (s2, s6) (s3, s4) (s3, s7) (s4, s5) 
(s5, s7) (s6, s7) 
*** Configuring hosts
h1 h2 h3 h4 h5 
*** Starting CLI:
*** Starting controller
*** Starting 7 switches
s1 s2 s3 s4 s5 s6 s7 
*** Starting CLI:
mininet> pingall
*** Ping: testing ping reachability
h1 -> X X X X 
h2 -> X X X X 
h3 -> X X X X 
h4 -> X X X X 
h5 -> X X X X 
*** Results: 100% dropped (20/20 lost)

But when i run pingall, the output in the routeflow still running, like these:

INFO:rfproxy:routemod sent to datapath (dp_id=0x1)
INFO:rfproxy:routemod sent to datapath (dp_id=0x1)
INFO:rfproxy:routemod sent to datapath (dp_id=0x2)
INFO:rfproxy:routemod sent to datapath (dp_id=0x2)
INFO:rfproxy:routemod sent to datapath (dp_id=0x1)
INFO:rfproxy:routemod sent to datapath (dp_id=0x1)
INFO:rfproxy:routemod sent to datapath (dp_id=0x3)
INFO:rfproxy:routemod sent to datapath (dp_id=0x3)
INFO:rfproxy:routemod sent to datapath (dp_id=0x2)
INFO:rfproxy:routemod sent to datapath (dp_id=0x2)
INFO:rfproxy:routemod sent to datapath (dp_id=0x4)
INFO:rfproxy:routemod sent to datapath (dp_id=0x4)
INFO:rfproxy:routemod sent to datapath (dp_id=0x3)
INFO:rfproxy:routemod sent to datapath (dp_id=0x3)
INFO:rfproxy:routemod sent to datapath (dp_id=0x5)
INFO:rfproxy:routemod sent to datapath (dp_id=0x5)
INFO:rfproxy:routemod sent to datapath (dp_id=0x4)
INFO:rfproxy:routemod sent to datapath (dp_id=0x4)
INFO:rfproxy:routemod sent to datapath (dp_id=0x5)
INFO:rfproxy:routemod sent to datapath (dp_id=0x5)
INFO:rfproxy:routemod sent to datapath (dp_id=0x1)
INFO:rfproxy:routemod sent to datapath (dp_id=0x1)
INFO:rfproxy:routemod sent to datapath (dp_id=0x2)
INFO:rfproxy:routemod sent to datapath (dp_id=0x2)
INFO:rfproxy:routemod sent to datapath (dp_id=0x4)
INFO:rfproxy:routemod sent to datapath (dp_id=0x4)
INFO:rfproxy:routemod sent to datapath (dp_id=0x3)
INFO:rfproxy:routemod sent to datapath (dp_id=0x3)
INFO:rfproxy:routemod sent to datapath (dp_id=0x5)
INFO:rfproxy:routemod sent to datapath (dp_id=0x5)


Thankyou!

me

unread,
Mar 19, 2016, 5:23:41 AM3/19/16
to RouteFlow
Hi

I mean what i want to ask:

For example I want to connect switch3 eth3 with switch7 eth3.

But in the output, i found that switch3 eth2 connected to switch7 eth2
 INFO:openflow.discovery:link detected: 00-00-00-00-00-03.2 -> 00-00-00-00-00-07.2

And in the end i found the link has broken, right? INFO:openflow.discovery:link timeout: 00-00-00-00-00-03.2 -> 00-00-00-00-00-07.2
Reply all
Reply to author
Forward
0 new messages