Trying to set up Choregraphe to run the virtual Nao robot on macOS

Skip to first unread message

Mahla Nasrollahi

Nov 18, 2020, 9:46:32 AM11/18/20
to ROS Sig Aldebaran
Hi all,

I have been trying to install Choregraphe Suite on my macOS Big Sur (v11.0.1) from the softbankrobotics website:

I have tried downloading both:
  1. Choregraphe Setup
  2. Choregraphe Binaries
I tried the setup for option 1 but the 'choregraphe-suite-' was not opening. 

I tried the setup for option 2 and I could get access to the file contents of 'choregraphe-suite-'. I went to click on choregraphe-suite-\bin\naoqi-bi unix executable file but I kept getting these messages: 
Screenshot 2020-11-18 at 14.37.36.png
After clicking cancel, I got these:
Screenshot 2020-11-18 at 14.30.27 4.png

I also tried running the Choregraphe unix executable file as well and got this:
Screenshot 2020-11-18 at 14.40.07.png 

I would appreciate if anyone can help on how I can set up the virtual environment on my MacBook Pro.

OS: macOS Big Sur
Version: 11.0.1

Thank you in advance,
Mahla Nasrollahi

LeRoy Wong

Feb 12, 2021, 12:26:52 PM2/12/21
to ROS Sig Aldebaran
I was able to install Choregraphe on a Mac with Mojave, and then I copied the Choregraphe files from the Applications folder on my Mojave Mac to my Mac with Big Sur. As far as I can tell, it seems to work okay but we have only made fairly basic programs.
Reply all
Reply to author
0 new messages