Have anyone succeeded in working pepper simulation perfectly in indigo ROS gazebo 2.2.3?

584 views
Skip to first unread message

Mach Free

unread,
Feb 7, 2017, 6:10:09 AM2/7/17
to ROS Sig Aldebaran


I am trying to simulate pepper in Gazebo 2.2.3 indigo Ros

I have succeeded in loading and moving the arm, head and etc with moveit. However, I can not figure out how to move the base of the pepper robot.

When I publish /cmd_vel, the robot jiggers and falls down to the ground. Moreover, it does not work with moveit. (when i use moveit it says virtual_odom is not there)

I even tried to connect with the naoqi ALProxy, but it keeps giving me errors that the IP is not able to connect. which the IP address is 127.0.0.1 and even tried the ifconfig IP for ROS_MASTER.

If anyone could help me, it would be very much appreciated.

Thank you.

Félix Escalona

unread,
Feb 17, 2017, 8:12:33 AM2/17/17
to ROS Sig Aldebaran
I'm having exactly the same issue as yours, and cannot move the head too. ¿Have you found any solution?
Thank you.

Giovanni Claudio

unread,
Feb 17, 2017, 8:30:56 AM2/17/17
to ROS Sig Aldebaran
I have the same problem, the command /cmd is not working. 

I am not sure, but I think that it is not possible to control the virtual Pepper in Gazebo with Naoqi, but only using ROS topic. 

Natalia Lyubova

unread,
Feb 17, 2017, 8:50:15 AM2/17/17
to ROS Sig Aldebaran
Yes the solution is to implement it :)

Wheel implementation is wrong here: : https://github.com/ros-naoqi/pepper_robot/blob/11e37bf881ed36ad3c7bb68d3f0815ab1efea504/pepper_description/urdf/pepper1.0_generated_urdf/pepperGazebo.xacro#L725

If you find a way to fix it, please do a Pull request
Reply all
Reply to author
Forward
0 new messages