Setup Checklist - README

7966 views
Skip to first unread message

Saul

unread,
Jun 29, 2011, 10:56:31 AM6/29/11
to roConnect
If you are having issues on initial setup please verify the following
steps have been performed:

WINDOWS

1. Downloaded and installed WAMP
2. Started WAMP by clicking on Start > All Programs > WampServer >
Start WampServer
-Also there should be a green "W" icon in the system tray (bottom
right-hand corner of the screen)
-Enable php_sockets (see http://www.ro-connect.com/support.php#3)
3. Downloaded roConnect Web App from http://www.ro-connect.com/download.php
(step 2)
4. From the unzipped download (roConnect.zip) move the "roku" folder
to C:/wamp/www/
5. Browse to http://localhost/roku

MAC

1. Downloaded and installed MAMP
2. Started MAMP by going to /Applications/MAMP/ and clicking on the
MAMP app icon
3. Downloaded roConnect Web App from http://www.ro-connect.com/download.php
(step 2)
4. From the unzipped download (roConnect.zip) move the "roku" folder
to /Applications/MAMP/htdocs/
5. Browse to http://localhost:8888/roku

If you still have errors please review the forum or email support@ro-
connect.com with the error your are receiving.

James

unread,
Jul 4, 2011, 1:25:14 PM7/4/11
to roConnect
Help in step 4 you say to move the roku folder but i cant find the
folder after downloading it and unzipping it, I just find 200 other
files. Am i suppose to make the folder and move everything into it?

On Jun 29, 9:56 am, Saul <ad...@ro-connect.com> wrote:
> If you are having issues on initial setup please verify the following
> steps have been performed:
>
> WINDOWS
>
> 1. Downloaded and installed WAMP
> 2. Started WAMP by clicking on Start > All Programs > WampServer >
> Start WampServer
>         -Also there should be a green "W" icon in the system tray (bottom
> right-hand corner of the screen)
>         -Enable php_sockets (seehttp://www.ro-connect.com/support.php#3)
> 3. Downloaded roConnect Web App fromhttp://www.ro-connect.com/download.php
> (step 2)
> 4. From the unzipped download (roConnect.zip) move the "roku" folder
> to C:/wamp/www/
> 5. Browse tohttp://localhost/roku
>
> MAC
>
> 1. Downloaded and installed MAMP
> 2. Started MAMP by going to /Applications/MAMP/ and clicking on the
> MAMP app icon
> 3. Downloaded roConnect Web App fromhttp://www.ro-connect.com/download.php
> (step 2)
> 4. From the unzipped download (roConnect.zip) move the "roku" folder
> to /Applications/MAMP/htdocs/
> 5. Browse tohttp://localhost:8888/roku

alwaysbelieve1

unread,
Jul 4, 2011, 4:45:54 PM7/4/11
to roConnect
You're probably opening the roku folder without realizing it. Clear
your browser cache, redownload, unzip and then open the first folder.
It's in there.

Morely the IT Guy

unread,
Jul 21, 2011, 1:36:20 PM7/21/11
to roConnect
The biggest problem is using the built-in zip reader in Windows. Do
yourself a favor, download and install 7-Zip (it's free) and use it to
open zip, rar, and lots of other compressed file types. You can then
just drag and drop the roku folder where you want it.

Paul French

unread,
Aug 25, 2011, 12:17:16 AM8/25/11
to roConnect
The problem with this help is that the new version of roConnect is not
a zip file.

It is an exe file that opens a command prompt that auto installs wamp
server and then sits there saying "Stopping wamp" forever and I cannot
get it to do anything.

James

unread,
Oct 8, 2011, 11:20:26 AM10/8/11
to roConnect
There is a Zip version of the web client found @ http://www.ro-connect.com/roConnect.zip
. The .exe version does not like to install on my storage drives. It
gets errors saying cant find php.ini to enable sockets and curl. Also
when installed on those drives it has problems with permissions and
cant obtain access to the video files on the server. Version 2.0 has
been a really cool insight on what will come with ro-Connect , but as
of right now is completely useless to me with all the indexing
problems i've been having. If you re-index your video files it will
wipe all saved metadata and make you re-enter all the info again.
This is not pleasant when you have 740+ videos. I wish i could revert
back to 1.2 where I had everything perfect.

Heffie

unread,
Oct 8, 2011, 10:48:15 PM10/8/11
to roConnect
Anyway that i can get a copy of 1.2?

AK

unread,
Jun 23, 2012, 5:52:34 PM6/23/12
to ro-co...@googlegroups.com

AK

unread,
Jun 23, 2012, 5:54:15 PM6/23/12
to ro-co...@googlegroups.com

This is an Error message I'm seeing when I attempt to Config.   ERROR: C:/wamp/bin/apache/Apache2.2.17/conf/httpd.conf is not a valid file!



On Wednesday, June 29, 2011 10:56:31 AM UTC-4, Saul wrote:

neoikon

unread,
Jul 23, 2012, 5:46:10 PM7/23/12
to ro-co...@googlegroups.com
Setup seems to have gone smooth and it finds my Roku.  

When I index for files, it seems to freeze half way through.

Also, any plans to support MKV files?  Most of my files are MKV.

On the Roku, then I try and play a movie, nothing happens (immediate exits).

Thanks!
Daniel


Enska

unread,
Aug 12, 2012, 10:13:37 AM8/12/12
to ro-co...@googlegroups.com
hi there!
i got everything working just like described below. i am running things on my mac.
i am on my localhost page and:
on the media tab, i see my videos listed neatly.
on the roku tab, i see both my roku's listed and i can click on the "connect" button. i click connect, but then nothing happens. 
my roconnect app on my roku still shows the roconnect setup page. 
i can't get passed that view on my tv...
in other words, i am not streaming anything nor i can see the videos on my tv.

any advice would be much appreciated. thanks in advance!

Enska



On Wednesday, June 29, 2011 10:56:31 AM UTC-4, Saul wrote:

Jeremy

unread,
Aug 24, 2012, 7:19:31 PM8/24/12
to ro-co...@googlegroups.com
The last time I saw this problem, it turned out to be an issue with the person's router.  I think he applied a firmware update to it, and that solved it.  If you try connecting the roku using an ethernet cable, instead of wireless, you can see if that works (at that point you should be bypassing the router) and, if so, then try an update to get it to work with wireless.  Or maybe it will work with wireless after you successfully connect, it was never really clear what the problem really was.


On Friday, August 24, 2012 3:42:19 PM UTC-7, Fusoya wrote:
I am having this exact issue - I have followed all other steps and everything else if fine.  The Roku box shows up with green light and I can add media - but when I click connect nothing happens.

Any ideas?

Frank Evans

unread,
Sep 2, 2012, 9:25:20 PM9/2/12
to ro-co...@googlegroups.com
I love my Roku but I can't believe how buggy and user-unfriendly the whole Ro-Connect experience has been. This is why Apple is eating everyone's lunch - they make stuff that works.

Devin Lyttle

unread,
Jan 6, 2013, 4:07:04 PM1/6/13
to ro-co...@googlegroups.com
I've followed these instructions to the letter, yet when I attempt to connect to http://localhost:8888/roku it just sits there and spins, but never connects. I'm running OS 10.6.8 using the latest version of Chrome. The only sign of life I get from that URL is "Waiting for localhost..." appears in the progress bar at the bottom. I've tried rebooting and still can't connect. I'm wondering if this is an issue with the server or if it's something on my end. Hoping someone can offer some insight, since I'm out of ideas. 

I knew I should've just gotten a Boxee.
 

On Wednesday, June 29, 2011 10:56:31 AM UTC-4, Saul wrote:

Jake Lewis

unread,
Jan 17, 2013, 12:27:41 AM1/17/13
to ro-co...@googlegroups.com

I've set up the server and am trying to connect to my Roku, via the Roku tab at http://localhost/roku/roku.php.  I just get the purple timer and 'Searching'.

The text on the left says "To manually add a Roku player click the "Add Roku" button and supply the Roku's IP address (i.e. 192.168.1.1) and any name.",
but, very annoyingly, there is no actual button.

I've tried the suggestions in the FAQ concerning Multicast packets and enabling / disabling various php modules.

I have static IP assigneded to both the server and the Roku, so I figure it would be easier if I just type the data in a config file somewhere - where should I do this?

Jake

On Wednesday, June 29, 2011 10:56:31 AM UTC-4, Saul wrote:

Roy Markowitz

unread,
May 17, 2013, 9:55:25 AM5/17/13
to ro-co...@googlegroups.com
Saul: Chrome browser does not allow me to add alias to server configuration file. I reads: Do it manually. Why is that?


On Wednesday, June 29, 2011 10:56:31 AM UTC-4, Saul wrote:

Herbert Coleman

unread,
Dec 22, 2014, 4:23:50 PM12/22/14
to ro-co...@googlegroups.com
All this is working just fine.  I have an external hard drive with tons of movies, music and photos.  I've been have trouble getting the configuration to accept the the external drive location.  I'm on a Mac so I tried using /Volumes/{harddrive name}/{folder on hardrive}/ but it still says "Volumes/{harddrive name}/{folder on hardrive}/ is not a x valid directory."  Any ideas on how to get it to see the external drive on a Mac?

Sam Beresford

unread,
Dec 29, 2014, 7:53:12 PM12/29/14
to ro-co...@googlegroups.com
I couldn't get it to work for the longest time, finally now, I got it working. 

Gotta go to the WAMP server and tell it to "Put Online" And it works!

Thanks for the awesome setup! smooth
Message has been deleted

VZ

unread,
Jan 8, 2015, 3:52:39 PM1/8/15
to ro-co...@googlegroups.com
On my TV, I get "can't find valid server at <ip address>". The IP adress is set correctly, but the "solution" posted is to completely disable your firewall. That doesn't sound very safe. My router allows selective firewall disabling Need to know port numbers, protocols, etc. 

Firewall Application Profile Definition

If the desired application requires multiple ports of both TCP and UDP ports, you will need to add multiple definitions. Current definitions for this profile are shown in the Definition List below.

Application Profile Name
Create Application Definition
ProtocolTCPUDP
Port (or Range)FromTo
Protocol TimeoutTCP default 86400 seconds, UDP default 600 seconds
Map to Host PortDefault/blank = same port as above
Application Type
Note: In some rare instances, certain application types require specialized firewall changes in addition to simple port forwarding. If the application you are adding appears in the application type menu above, it is recommended that you select it.


Any help? Thx.


Reply all
Reply to author
Forward
0 new messages