can't get RGeo::Geos.supported? to be true

740 views
Skip to first unread message

stephen deese

unread,
Nov 6, 2012, 1:15:07 PM11/6/12
to rgeo-...@googlegroups.com
I am following Daniel Azuma's great series on Rails and PostGis (http://www.daniel-azuma.com/blog/archives/191).

I am working on a windows x64 system and have installed RGEO and GEOS.

I couldn't get the code is Azuma's #8 blog post working.  I get "RGeo::Error::RGeoError: GEOS is not available, but is required for correct interpretation of polygons in shapefiles"

When i try "RGeo::supported?"  I get false.

Can someone help my fix this (I know... windows is a pain)

Thanks

Daniel Azuma

unread,
Nov 6, 2012, 2:32:17 PM11/6/12
to RGeo-Users
The RGeo-GEOS integration via C extension isn't Windows-compatible (and, not being a Windows dev myself, I don't know how to make it compatible), but I have heard some people were able to get the FFI-based integration to work. Try installing the ffi-geos gem and see if that gets RGeo::Geos.supported? to return true.

Daniel

stephen deese

unread,
Nov 14, 2012, 8:37:43 PM11/14/12
to rgeo-...@googlegroups.com
Daniel,

Thanks for taking the time to answer.  Great article series by the way!  I finally switched to Mac (this was the last straw).  Rails dev on windows was just too painful.

Thanks
Stephen
Message has been deleted

srs...@gmail.com

unread,
Jul 29, 2017, 6:56:31 PM7/29/17
to RGeo-Users
In case someone else is landing here for the same issue:

It does work on windows 100%.
Please follow these links.

Reply all
Reply to author
Forward
0 new messages