Touchtone-pro, has anybody made it work with RF Explorer

58 views
Skip to first unread message

daveed...@gmail.com

unread,
Nov 6, 2021, 3:54:21 AM11/6/21
to RF Explorer
I bought the app and I’m having trouble running It.
The application launches as is detecting the RF Explorer, however the Start button in gray out and I don’t see a way to start the scanning.
I activated  it and I am running the latest USB to UART software driver 6.0.2
It seems as if is an awful small software company so I'm not holding my breath on them getting back to me with an answer anytime soon.

oh itsyou

unread,
Nov 6, 2021, 4:22:46 AM11/6/21
to RF Explorer
Hello,

The software works on the latest versions of MacOS -- a few thousand users can attest to that.  With the introduction of Catalina (MacOS 10.15) Apple broke all 3rd-party USB-to-UART software driver installations -- including the one from Silicon Labs (a very large company and manufacturer of USB chips) -- when they changed their driver requirements. Here's a link that should help and which offers a solution:
http://nutsaboutnets.com/faq/installing-drivers-on-latest-versions-of-macos/

In February Silicon Labs finally released a new version of their USB driver that fixes the problem.  The latest release of Touchstone-Pro (MacOS) uses the new Silicon Labs USB driver -- here's a link:
http://nutsaboutnets-osx.s3.amazonaws.com/Touchstone-Pro.dmg

The installation program includes two icons -- one for Touchstone-Pro and one for Silicon Labs.  Be sure to install both and reboot after installing the new driver.

Also -- you might try different USB cables, they are not all created equal.  USB cables that do not support BOTH power and data are the most common problem.

Also -- make sure the baud rate is set to 500 Kbps (and not 2.4 Kbps).

Regards,
the "awful small software company"

daveed...@gmail.com

unread,
Nov 6, 2021, 2:13:34 PM11/6/21
to RF Explorer
Thank you for the quick reply, 
I'm running Catalina 10.15.5
I also installed the latest Silicon Labs app (v. 6.0.2). and just now tried a different cable. I rebooted the computer several times as well.

The program sees the RF Explorer.  I tested it by trying to boot up the program in without it connected  and get this message:
Screen Shot 2021-11-06 at 11.04.36 AM.png
Also if I disconnect the USB cable while the app is running I get this:
Screen Shot 2021-11-06 at 11.03.25 AM.png

So I believe the systems sees the RF Explorer,
However when the program launches the Start option is just not available.:
Screen Shot 2021-11-06 at 11.02.33 AM.png

you wrote:
[Also -- make sure the baud rate is set to 500 Kbps (and not 2.4 Kbps).]

Where do I set up the baud rate? I don't see the option.

Thank you so much,








daveed...@gmail.com

unread,
Nov 6, 2021, 2:26:23 PM11/6/21
to RF Explorer
I changed the baud rate to 500kps on the RF explorer, still not working
Reply all
Reply to author
Forward
0 new messages