RC2014/ESP8266/Telnet/Linux/Small Computer Monitor problem

90 views
Skip to first unread message

OldGit

unread,
Dec 27, 2021, 3:08:39 PM12/27/21
to retro-comp
Hello All,
I've just built an RC2014 Classic II with an add-on ESP8266 module. It works fine,in almost all respects. If I disable the ESP8266 I can connect via USB/FTDI  from a Linux box and everything in SCM works fine, including uploading Intel hex files.

However, if I remove the FTDI, re-enable the ESP8266 and connect with telnet, I cannot get SCM to accept Intel hex file uploads. I've tried:

1. Telnet from a terminal window in line mode
2. Telnet from a terminal window in character mode
3. Putty in telnet mode.

All of these give 'Bad command'

Any ideas, anyone? I'd rather not be tethered to it via USB

Thanks in advance for any help.

Bob Dunlop

unread,
Dec 28, 2021, 1:54:56 AM12/28/21
to retro-comp
Uhm telnet has a habit of inserting control sequences of it own into the data stream which may be upsetting SCM, telnet expects the other end to be a telnet receiver that understands
and strips the hidden control sequences.  I suspect the ESP8266 does not understand them and is passing them through.

Look for a package net-analyzer/netcat (others are available), this has tools to create raw connections without injecting extra sequences.

HTH

OldGit

unread,
Dec 28, 2021, 3:16:06 AM12/28/21
to retro-comp
Hmm, thanks Bob. I installed Wireshark to take a look and think I may have a clue. Ordinary typed data is transmitted and received fine. Each line is terminated with CRLF, but with pasted data, the LF is missing. I suspect that SCM requires the LF as a line terminator. Doesn't help me solve the problem though.

OldGit

unread,
Dec 28, 2021, 5:05:14 AM12/28/21
to retro-comp
Putty allows a raw connection, and it works as you suggested. Many thanks.

Issue solved.
Reply all
Reply to author
Forward
0 new messages