[reportlab-users] reportlab-3.6.10 and pillow

23 views
Skip to first unread message

Antonio T. sagitter

unread,
Jun 17, 2022, 8:34:57 AMJun 17
to reportlab-users, Robin Becker
Hello everyone.

Reportlab 3.6.10 requires Pillow >= 9 but it still works with Pillow
8.3.2; is it feasible "forcing" Reportlab 3.6.10 to use Pillow-8.3.2
when Pillow 9 is not available?

Red Hat bug ticket about this question:
https://bugzilla.redhat.com/show_bug.cgi?id=2097817

Best regards.
--
---
Antonio Trande
Fedora Project
mailto: sagi...@fedoraproject.org
GPG key: 0xCC1CFEF30920C8AE
GPG key server: https://keyserver1.pgp.com/
OpenPGP_0xCC1CFEF30920C8AE.asc
OpenPGP_signature

Claude Paroz

unread,
Jun 17, 2022, 3:00:12 PMJun 17
to reportl...@lists2.reportlab.com
Le 17.06.22 à 14:34, Antonio T. sagitter a écrit :

> Hello everyone.
>
> Reportlab 3.6.10 requires Pillow >= 9 but it still works with Pillow
> 8.3.2; is it feasible "forcing" Reportlab 3.6.10 to use Pillow-8.3.2
> when Pillow 9 is not available?
>
> Red Hat bug ticket about this question:
> https://bugzilla.redhat.com/show_bug.cgi?id=2097817

AFAIK, the minimal pillow version is mostly there because older versions
are affected by several security issues.
If the distro is backporting security issues to old pillow versions,
then you should be able to "manually" downgrade the pillow requirement
without impact on ReportLab.
But Robin might give some more enlightment to this question.

Claude
--
www.2xlibre.net
_______________________________________________
reportlab-users mailing list
reportl...@lists2.reportlab.com
https://pairlist2.pair.net/mailman/listinfo/reportlab-users

Robin Becker

unread,
Jun 18, 2022, 3:16:19 PMJun 18
to Antonio T. sagitter, reportlab-users
On 17/06/2022 13:34, Antonio T. sagitter wrote:
> Hello everyone.
>
> Reportlab 3.6.10 requires Pillow >= 9 but it still works with Pillow 8.3.2; is it feasible "forcing" Reportlab 3.6.10 to
> use Pillow-8.3.2 when Pillow 9 is not available?
>
> Red Hat bug ticket about this question:
> https://bugzilla.redhat.com/show_bug.cgi?id=2097817
>
> Best regards.
I think you can load reportlab

this sequence works for me


$ python310 -mvenv xxx
$ cd xxx
$ . bin/activate
$ pip install reportlab
$ pip uninstall pillow -y
$ pip install pillow==8.3.2
Collecting pillow==8.3.2
Downloading Pillow-8.3.2-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (3.0 MB)...
......
Installing collected packages: pillow
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This
behaviour is the source of the following dependency conflicts.
reportlab 3.6.10 requires pillow>=9.0.0, but you have pillow 8.3.2 which is incompatible.
Successfully installed pillow-8.3.2

--
Robin Becker

Robin Becker

unread,
Jun 18, 2022, 3:22:25 PMJun 18
to Antonio T. sagitter, reportlab-users
.........

>
> $ python310 -mvenv xxx
> $ cd xxx
> $ . bin/activate
> $ pip install reportlab
> $ pip uninstall pillow -y
> $ pip install pillow==8.3.2
> Collecting pillow==8.3.2
>   Downloading Pillow-8.3.2-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (3.0 MB)...
> ......
> Installing collected packages: pillow
> ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This
> behaviour is the source of the following dependency conflicts.
> reportlab 3.6.10 requires pillow>=9.0.0, but you have pillow 8.3.2 which is incompatible.
> Successfully installed pillow-8.3.2
>
I did this because my pip --help didn't show the no-dependencies option, but this sequence also worked

$ pip install reportlab --no-dependencies
$ pip install pillow==8.3.2

Reply all
Reply to author
Forward
0 new messages