Error: package or namespace load failed for ‘rJava’:

Skip to first unread message

Nicholas Michalak

May 18, 2017, 9:28:14 PM5/18/17
to ReporteRs
Hi--I just bought a new Macbook Air. Siera OSX. I can't figure out this error. Have used and love this package, so I hope someone can help! Thank you!

Error: package or namespace load failed for ‘rJava’:
 .onLoad failed in loadNamespace() for 'rJava', details:
  call: dyn.load(file, DLLpath = DLLpath, ...)
  error: unable to load shared object '/Library/Frameworks/R.framework/Versions/3.4/Resources/library/rJava/libs/':
  dlopen(/Library/Frameworks/R.framework/Versions/3.4/Resources/library/rJava/libs/, 6): Library not loaded: @rpath/libjvm.dylib
  Referenced from: /Library/Frameworks/R.framework/Versions/3.4/Resources/library/rJava/libs/
  Reason: image not found

John Vida

Jun 2, 2017, 2:41:10 PM6/2/17
to ReporteRs
Hi Nicholas, check what java version you have ( 32 or 64 bit Java). R looks for same bit version. and then install rJava.

Aug 13, 2018, 7:08:31 PM8/13/18
to ReporteRs
I have the same error!
How do I check version of java?
Thanks! David

Audrey Lacroix

Aug 29, 2018, 4:10:25 AM8/29/18
to ReporteRs

I got the same error message, and I am stuck.
Did you find any solution??
Thanks a lot!!
Reply all
Reply to author
0 new messages