el8 rootfs arch

5 views
Skip to first unread message

Bjarne Saltbæk

unread,
May 27, 2019, 4:14:27 PM5/27/19
to redsleeve-users
To Jacco.

Did you had the same ARCH issue with yum on the rootfs you made.
I have the below issue on both my newly installed RPI and on the first Qemu system:

--- cut ---
[root@localhost ~]# yum -y install rsyslog
RedSleeve-8 - AppStream                                                                                                                                                                                      1.8 MB/s | 5.2 MB     00:02
RedSleeve-8 - BaseOS                                                                                                                                                                                         1.0 MB/s | 2.4 MB     00:02
RedSleeve-8 - RedSleeve                                                                                                                                                                                       23 kB/s |  42 kB     00:01
Last metadata expiration check: 0:00:01 ago on Fri Jun 22 11:17:40 2018.
Error:
 Problem: conflicting requests
  - package rsyslog-8.37.0-9.el8.armv5tel does not have a compatible architecture
  - nothing provides libestr.so.0 needed by rsyslog-8.37.0-9.el8.armv5tel
  - nothing provides libfastjson.so.4 needed by rsyslog-8.37.0-9.el8.armv5tel
  - nothing provides libestr >= 0.1.9 needed by rsyslog-8.37.0-9.el8.armv5tel
  - nothing provides logrotate >= 3.5.2 needed by rsyslog-8.37.0-9.el8.armv5tel
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@localhost ~]#
--- cut ---

if I manually add

arch=armv5tel to [main] in /etc/yum.conf everything works.

Could your rootfs miss some packages? I can try creating a rootfs from the @core group from the RH8 DVD and crosscheck with your rootfs.

BR,
Bjarne





Sendt fra Outlook

Jacco Ligthart

unread,
May 27, 2019, 6:33:23 PM5/27/19
to redslee...@googlegroups.com

Hi Bjarne,


Yes I had the same issue, with the same solution.


I had the impression that the error is "normal". I do indeed try to install armv5 packages on an armv7 machine. I guess that the "right" solution is, to tell the system that those are compatible architectures. I don't recall where that can be set.


I remember similar issues on arm8 machines. There the solution was to set "armv5tel-redhat-linux-gnu" in /etc/rpm/platform.


I expect tp package one of these solutions in a final version of one of the packages. Maybe as part of debranding dnf. Or maybe as part of redsleeve-release.


Jacco

--
You received this message because you are subscribed to the Google Groups "redsleeve-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to redsleeve-use...@googlegroups.com.
To post to this group, send email to redslee...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/redsleeve-users/AM0PR05MB588996FCD602ACFB716B8EB4C21D0%40AM0PR05MB5889.eurprd05.prod.outlook.com.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages