invisible corridors in Nethack 3.6.7

Skip to first unread message


Sep 8, 2023, 1:13:38 AMSep 8
In the Nethack application (as opposed to NethackW), the corridors are not shown. I tried fiddling with the lit_corridor option to no avail. Pretty much unplayable because of fumbling in the dark in corridors. I like the tiled version, but I can put both versions to use. Anyone else experience this? Some option must fix the concern.

Pat Rankin

Sep 8, 2023, 4:07:06 PMSep 8
This is a Terminal bug in Windows 11 that affects nethack when
it is displayed with IBMgraphics. The default font shown in the
default size doesn't render the checkerboard special character

Changing either the font or its size (or both) reportedly fixes this.
(I've seen the problem myself but never verified the workaround.)
That needs to be done outside of nethack. Setting up a desktop
shortcut to run the program and setting the font in the shortcut
should work, or you can modify the Terminal program's settings
to override its default.

Alternatively, you could switch from IBMgraphics to the default
(plain ASCII) characters, or force the corridor symbol to be '#'
or some other character in your run-time configuration file.
OPTIONS=S_corridor:35 would set corridor to ASCII character
35 which is the decimal value for '#'. If you do that, it needs to
come after any OPTIONS=symset:IBMgraphics (or deprecated
OPTIONS:IBMgraphics) which sets it to checkerboard.

Yosemite Sam

Sep 8, 2023, 9:44:45 PMSep 8
Thank you, this worked. I was able to solve it within the application. Right clicking somewhere and choosing Settings...
Reply all
Reply to author
0 new messages