Street Fighter 2/Gottlieb System 3 Problems

80 views
Skip to first unread message

dimperio

unread,
Nov 15, 2010, 11:16:15 PM11/15/10
to
I picked up a Street Fighter 2 machine that suppsibly came from Italy
that someone could not get running. I was looking for a winter project
but now find myself fooling around with it nightly. I have a couple
things that I can't figure out. First of all the machine only will
boot when I turn the machine on and then go to the A2 power supply
board and turn the power supply pot down and then back up. At this
point all the boards are flashing properly. I had a second power
supply board and it does something thing very similiar. I doubt that
both of these boards are bad. Enough power isn't getting to the CPU
board for it to boot properly. The only way I can prove that is to
take a reading from the A1P1 connector (I will do that tomorrow).
Another problem is that all the information isn't fitting on the
display. Wording is cut off the top of the display and I only see the
the top half of the scores for player 3 and four. It is almost like
the resolution on the display doesn't match up with what is being
outputed by the display board. I tried another display controller and
it didn't work either. It almost seemed like it was showing a gassed
out DMD but it does work with the other controller board but it just
doesn't fit on the sreen. Anyone have any ideas on this? Another real
confusing problem is that I can't seem to get the ball to launch to
the plunger. It do not hear any of the coils fire that move the ball
to the plunger. If I put some balls in the machine and hit them in the
backfield they do not kick out of the holes and if I let them drain
they do not kick the ball to the trough. Lastly it now seems like the
left ramp flap want to go up and down all the time. In test mode both
of these ramp flap work fine but when I start a game the left one want
to keep on going up and down. I have a new rotten dog amusements
driver board in this machine so I pretty confident that that board is
working properly. I examined this area and everything looks right.

Any input on any of these problems is greatly appreciated.

Lloyd Olson

unread,
Nov 15, 2010, 11:20:27 PM11/15/10
to
Any switches that let the game know if it's up or down ? I'd start there.
LTG :)

"dimperio" <tdim...@northwesternrec.com> wrote in message
news:31386ae1-c954-40d3...@r29g2000yqj.googlegroups.com...

YenningComity

unread,
Nov 16, 2010, 1:55:19 PM11/16/10
to
I own one of these and depending on which ramp there is either an opto
or switch that is having an issue. The game changes the position of
the ramp after you make a shot over or under it. Is the game
registering anything when you drop the balls in the kick outs? You
did not say if those coils fired during the tests, but if they are
then I would suspect an issue in the wiring of your switches since you
are using a new board.

dimperio

unread,
Nov 16, 2010, 9:29:15 PM11/16/10
to
I got the machine to boot and actually play. It got a lot of little
problems but I should be able to knock them off one by one. My last
big problem is that the only way I can get the machine to boot is to
crank up the pot on the power supply board on in the head of the
machine. I happen to have a couple extra Gottlieb Power transformers
and swapped out the one in the bottom of the machine. It still made no
difference. I still had to turn the pot down and then back up to get
it to boot properly. All the gottlieb power transformers I have came
out of machines from over seas (Japan, Italy). I think this cpu boot
problem has something to do with the fact that both of the power
transformers where used on machines that ran on different voltages
overseas. I must be missing something here. I'm going to replace the
pot on the power supply board in the back but my guess is that it
isn't going to make a difference. I read marvins pinball repair guid
and it says that the jumper on the tranformer on the bottom of the
machine controls wether it runs at 110V 0r 120V. I tried it with the
orange jumper and also with the red jumper and it made no difference.
It almost seems like I'm running on the wrong voltage and by me
cranking up the pot on the power supply board that it brings the
voltage up and allows the machine to boot. The problem is that when I
turn off the machine and turn it back on I have to turn the pot down
and then all the way back up to get it to boot.

Gott Lieb?

unread,
Nov 16, 2010, 9:34:35 PM11/16/10
to
It sounds like you have dead spots on the +5v adjustment pot. Those
pots are notorious for being crappy. It is one of the first things I
replace on a Sys80B or Sys3.

Jim

John T.

unread,
Nov 16, 2010, 10:00:50 PM11/16/10
to
> > and then all the way back up to get it to boot.- Hide quoted text -
>
> - Show quoted text -

I have recently had problems with the 12 v filter cap on the
transformer assembly.Most times it becomes A short and blows
fuses .Allthough A couple times I have seen it pull down the 12volts
to the 5 volt regulator assembly then slowly creeps up to spec after
the game has been on A minute or 2.In addition to Jims suggestion I
always change the 12 volt filter cap now as well.-John T.

Gott Lieb?

unread,
Nov 17, 2010, 7:08:03 AM11/17/10
to
Good point, John. I haven't seen the filtering caps fail on Sys3s
yet, but it is inevitable.

Jim

dimperio

unread,
Nov 17, 2010, 7:50:34 AM11/17/10
to
My next move is to replace the pot. I failed to mention that one of my
other problems is that a machine does a non stop patterned beeps when
turns on. When the machine boots properly there is no beeps. It
doesn't say low battery or anything like that but does have the
syptoms of a dead battery. I will replace that as well and report back.

fdj1965

unread,
Nov 18, 2010, 8:18:20 PM11/18/10
to

I have a Teed Off that has the same problem (beeps, no display, etc.),
but only when booting warm. Tried swapping out MPU and same, so forget
the battery. Maybe pot temp sensitive in my case. Anyway please post
if you replace and working. Thanks.

asan...@gmail.com

unread,
Aug 11, 2022, 11:57:16 AMAug 11
to
Hey man, did you ever get that sf2 pinball working? Mine has a bunch of similar issues and was hoping to hear how you resolved them, thanks.
Reply all
Reply to author
Forward
0 new messages