Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.

Cyclone issues - please help

Skip to first unread message

Josh Sharpe

Oct 18, 2005, 11:14:23 AM10/18/05
I googled and found this thread that pretty much describes what is
happening with my Cyclone. I'm not really saavy at fixing stuff, so I
was wondering if anyone can take a picture and circle on the board
where the thing is that is being talked about below. This post was from
6 years ago, so I'm not really sure if that solution worked. Has anyone
had a similar problem and was able to fix it?

Josh Sharpe

> I've had a Cyclone for about a year that has worked flawlessly. Recently it
> began behaving strangely.

> When first turned on there was a steady buzz in the head (like a coil, but
> softer) I quickly shut the game off. I then tried turning it back on and
> got a single knock from the knocker coil then nothing but GI. The next time
> I turned it on, steady buzz in the head.

> The fourth time I turned on the machine it came up normally. I played
> several games with no weirdness until the game just froze up. Turned it off
> and back on, game comes up normally.

> Current situation: game almost always fires up, but will freeze up,
> sometimes during gameplay, sometimes when its idling. Any ideas?

Double check your +5vdc ... it's possible it's running low due to a
filter cap. That's the 18,000 uf guy on the power supply PCB. Try a
one (anything over 15,000uf at 25vdc will work) and see if it helps.


Oct 18, 2005, 12:56:10 PM10/18/05
I do not have a Cyclone, but I think I recognize the part that is being
referred to. The power supply board will be the one with the large,
black heat sink. On it there will be a large tubular part with the
value 18000uF on it. That is the part that is being referred to in
your quote.

However to check one, you would need to use a capacitance meter that
can handle this value. I did this check this past weekend, but my
capacitance meter does not go up this high. Instead, I used the RC
decay of a known load.

The procedure requires some electronics expertise. Disconnect the 5V
to the CPU board, and connect a 1kOhm resistor and a DVM across the
capacitor. Turn the machine on, and verify 5V +/-0.2V on the DVM.
Then shut off power and see how long it takes to decay to 37% of the
original value. This is one time constant, and should take about 18
seconds or longer.

If this is true, the cap has not degraded.

Edward Cheung

Oct 18, 2005, 1:08:26 PM10/18/05
If it looks like it's the original capacitor, it probably needs to be
replaced after this much time. You can put your meter on AC voltage
and measure the AC ripple on the +5v line - if it's over .75/volt or so
replace the capacitor.

You might also try what beaver says, but because of the random nature
of the freezeup, if it is the power supply, the ac ripple would cause

Oct 18, 2005, 4:23:07 PM10/18/05
Try cleaning and tightening of the molex connector in the cabinet
coming from the transformer. The inline molex connector that feeds
everything except the GI. This corrected a huge problem for me that
had me thinking I had a blown CPU and/or power supply..........all
sorts of weird things going on with flashers stuck on and coils firing
when they shouldn't (especially on startup).

Ray Johnson - Action Pinball

Oct 18, 2005, 6:05:38 PM10/18/05

This type of problem/symptoms is very common in System 11 games, but I
wouldn't attribute it to *just* the 18kuf filter cap.

I've done a LOT of board swapping, chip replacing, grounding, isolating,
resoldering cracked joints, etc. to try and fix problems like this in
various System 11 games over the years (High Speed seems to be the worst)
and about the best solution (but not always the cure) is to replace the
bridge rectifier on the main power supply board. Good idea (ie: strongly
recommended) to replace the 18kuf filter cap at the same time.

The game is bascially halting or locking up before/during boot-up so the
cpu/system isn't running and the game is stuck in a "frozen" state.
Symptoms from this will vary, but essentially your game isn't booting up,
and this is usually due to power supply weaknesses/problems which are common
in a 17+ year old game that hasn't had a full overhaul/upgrade.

So I would start with the power supply:
1) Replace bridge rectifier- if anything, just for good measure. Go with
heavy-duty 35amp 400v unit for durability/reliability.
2) Replace C10 filter cap- original is axial lead 18,000 uF 25v. These
aren't made anymore, but we use 15,000 uF 50v radial lead as replacement,
and install 2 short jumper wires on the radial leads to connect the cap to
the PC board (later Sys 11 power supplies had mounting holes for both axial
and radial lead caps).
3) Check/reflow solder on backs of connector pins on all boards in backbox.
4) Power up and check voltages coming off the power supply to make sure
they're within tolerances- 4.9-5.2vdc on 5 volt logic rail, and 13.5-16.5
vdc on unregulated 12vdc line- these are the critical voltages for MPU board
to boot and run.

If problems still persist, then you most likely have a low-level problem on
the MPU board- failed component(s) and should probably consider repair by
qualified person/shop at that point.

We have the replacement heavy-duty rectifiers and filter caps in stock- see
our website at: for pics, prices, and online ordering.

Ray J.
Action Pinball & Amusement, LLC
Salt Lake City, Utah USA

We're serious about pinball. Anything else is just for fun!

Ray Johnson - Action Pinball

Oct 18, 2005, 6:09:30 PM10/18/05

If you have a 18,000 uF cap on that board, then it's most likely the
original part- these haven't been made in original specs for several years
now any anything you might find on a parts shelf somewhere should be assumed
to be an old part, too- having spent years on the shelf yet not used. Just
get a new modern replacement- we use 15,000 uF 50v radial-lead caps as
replacement for originals.

A 17 year old electrolytic cap should just simply be replaced- don't spend
time "testing" something that's spent most, if not all of it's usefulness
over the last 17 years. These big caps dry up inside over time and after so
many years, simply cannot be trusted to do a good job anymore (let alone for
any more years to come).

Just replace it. If you still have problems, you can at least rest assured
that this part has been replaced and can be ruled out as being a possible

Ray J.
Action Pinball & Amusement, LLC
Salt Lake City, Utah USA

We're serious about pinball. Anything else is just for fun!

"beaver" <> wrote in message

Oct 18, 2005, 8:02:25 PM10/18/05
I agree with Ray. but if you must test the cap, there is a far
easier way. Just set your manual DMM to low AC volts. with the
game on, put the DMM leads on the two leads of the cap. Any AC
reading of .250 volts AC or greater and that cap is toast. Heck
many would say anything over .100 volts AC and it's gone. Ray
is right, replace it.

Also as Ray said you can use a 15,000 mfd cap. Heck you can
use a 10,000 mfd cap too. Just make sure it's a NEW cap.

Josh Sharpe

Oct 19, 2005, 8:38:59 AM10/19/05
Thanks everybody,
I took my DMM to it just to check the reading, and it kept changing
between .1 and .2 volts. The game is at a friend's house, and of course
it wouldn't crash while I was there. Played a couple of games and
everything was fine. Decided to watch a tv show and leave the game on,
and heard the game reset while we were on the couch. Went to check it
out and the displays were dead, all GI was on. I took a picture of the
board, is it possible for anyone to edit it in paint and just circle
the things I need to replace on it. The last time I did any board work
. . . needless to say, was the last time I did any board work ;-)

-Josh Sharpe

0 new messages