Comp97: Incoherent Blather (4/5)

5 views
Skip to first unread message

C.E. Forman

unread,
Jan 10, 1998, 3:00:00 AM1/10/98
to












["I use stupid spoiler warnings," next on Jerry Springer.]














"Sunset over Savannah"
----------------------
-1 Making me think when trying to run it.
Kept getting TADS "out of memory" errors when running it with TR
2.2.0.4. Had to screw around putting TRX into my path to get it to
work. Normally I wouldn't take off for this, but I couldn't quit
TADS because of the memory errors, so I had to reboot my machine.
I hate rebooting my machine. If I wanted to reboot my machine a
lot, I'd install OS/2 on it. Plus *then* I hadta remember to use
TRX each time I ran the game, or I'd end up rebooting *again*.
Grrrrrr...

-1 "Guess the word."
In this case, guess the syntax. Guess the syntax other than the
syntax the hints tell you, because the syntax the hints tell you
doesn't work. I'm referring to "SIFT TRASH WITH SIEVE," which I was
trying, but which told me, "The sieve isn't something you can use to
sift things with." Consulted the hints after frustration set in,
found out I was using the correct phrasing all along, according to
the game. It's only when I stumbled upon "SIFT TRASH" (with no
noun) that I solved it, but by that time it had pissed me off
enough to lose a point. Also, why can't I "PICK UP MITE THEN PUT
MITE IN BOTTLE," since the text says I pick up the mite anyway when
I put it in the bottle? Why can't I simply drop the bottle with the
glass mite? Since glass is strewn all over the area, it should have
the same effect. More flexibility, please.

My score for "Sunset over Savannah": 8 points out of 10.

Did I finish it?: About halfway done.

Notes to the author:
--------------------
OH how I wish I hadn't encountered these two problems. "Sunset" was
fantastic! As was likely intended for my protagonist (though I didn't
get much more than halfway through it, being caught up in the rich
detail), the experience single-handedly renewed my faith in life. Or,
more appropriately, in the I-F competition. So what if I got stuck
playing four rotten games in a row? So what if this year's winner will
likely be a game that hit too close to my own work? Who cares? This
game made all the suffering in my last two days of playing worthwhile.
It was *fun*. It reminded me of why I'm supposed to be playing I-F in
the first place. I *needed* this.

Loved the level of detail and effort you put into this, although it did
mean I didn't get to see the entire thing before voting. This is a
definite go-back-and-finish, though. Lots of unnecessary detail
filling in the cracks for a seamless world. "Sunset" oozes
readability. Andrew Plotkin has taught you well, young Cockrum. I
actually enjoyed this *more* than "So Far," because it felt more down-
to-earth, giving a more solid grasp of what exactly was going on.

Excellent characterizations. With a few exceptions -- Bob from
"Spring," Maria from "Glowgrass" -- the gulls (loved the "Watership
Down" joke, BTW), mites and the little shrimp packed more depth than
the rest of the contest NPCs combined. Excellent interactivity.
Excellent prose. Not-so-excellent "revelation" scenes. You're bluntly
telling me what I'm feeling, instead of letting me find it myself.
You're going the opposite extreme of "So Far." There's a balance in
there somewhere, but -- I know, I know -- it's practically impossible
to hit square-on. No point lost over it, though, because the rest of
this game is just so perfectly done.

I guess I also owe God my end of the bargain: I can't do anything bad
ever again. (That pretty much blows "Shelton" right out of the water.
Ahh, hell, I'll do it anyway. What's the worst God can do? Send me to
hell? Adam Cadre says I'm going there anyway, for selling copies of
LGOP2 through Ye Olde Infocomme Shoppe.)

So. Nice job. Good game. About goddamn time I got one. Is two in a
row too much to ask for?

======================================================================

"Temple of the Orc Mage"
------------------------
Apparently so. The author of "The Obscene Quest of Dr. Aardvarkbarf"
strikes again!

-1 "Guess the word."
*Again* with the "climb up"/"climb down" but no "up" or "down"!
What *is* it with that? Is "down" really so difficult to implement
in TADS? Lotsa common synonyms missed too.

-1 Poor design/construction.
You seem to have made changes to your game after you wrote the
walkthrough. Or maybe you wrote the walkthrough first, then
programmed the game slightly differently. Whatever, the two are
different. Try to be more careful in the future. Further, I think
there are too many locked doors, too many puzzles solved simply by
examining things, and too many "put x in y" puzzles. (But with such
a limited command set, I don't know what I expected.)

-1 Cliched story/setting.
Fantasy dungeon. 'Nuff said.

-1 Lacking "something really cool."
The underground setting is the perfect place for truly fantastic
discoveries, such as FCD#3 in "Zork" and the inverted tree in
"Sherbet." You've got plain ol' treasure chests, slime-covered
walls and locked doors. Okay for a start, but kinda bland for the
entire game.

-1 Miscellaneous stuff that pissed me off.
Could use a few more clues in some areas, and a few less in others.
I flew through most this game. Cleared the first floor in five
minutes. From "Aardvarkbarf" I'd learned what kind of puzzles to
expect from you, so I knew to examine everything and to search a
lot. It's okay to eat food cuz it's only there as a workaround for
the TADS hunger daemon. Keys are reused a lot, but one object per
puzzle otherwise. A far greater challenge were the artificial
puzzles brought on by your code's shortcomings:
>LIGHT TORCH
Which do you mean, the torch or the large torches?
(Got around this by using 'it' in the previous room. Hee,
clever!)
The hidden door by the boulder, and the final puzzles required
peeking at the walkthrough, since crucial parts of them weren't
told to me by the game text.

My score for "Temple of the Orc Mage": 5 points out of 10.

Did I finish it?: One step away from victory.

Notes to the author:
--------------------
I liked this game a little better than the score reflects. (Damn this
inflexible scoring system!) Starts out good, nice 'n' linear, then
diverges without ever feeling too vast and overwhelming. Still a bit
on the easy side, but there was something really fun about it that I
just can't put my finger on. I just wish it had been a little more
amazing, with some cool discoveries on the way.

Can I digress for a moment? I hope so, for I simply must. For it is
once again time for yet another enthralling episode of... "STUFF THAT
C.E. FORMAN IS SICK OF!!!" Tonight, C.E. Forman is sick of...

* "Guess the key" puzzles. You have 397 keys. There is one door.
Which key do you use? The gold one? Nope. The iron-tungsten alloy
one? Nope. The ginsu key, which slices, dices, and makes French
fries in three different shapes? Nope. The French-fry key, which
you made with the ginsu key? Nope. The one with a handle that looks
like Danny DeVito? Nope...

* Desks with drawers in them, where "open drawer" works but "open desk"
does not. Since the drawer is part of the desk, why not allow this?
I get sick of seeing it time after time after time after time after
time. And I've no doubt TADS is powerful enough to support this.
(Provided you use the TADS Professional Edition, which allows "up"
and "down". God I am a smart-ass.)

* "Red herring" jokes. Okay, I get it! Red herring = false puzzle in
adventure to throw player off track. Red herring also = colored
fish. See? I **GET** it!! *Enough*, already!

* Authors entering two games in the same competition. Rybread Celsius
proved it last year, and you've proven it again. When an author does
two games, both suffer. You always see two mediocre games together,
never two great games by the same author. Does that tell anyone
anything?

This concludes tonight's riveting episode of "STUFF THAT C.E. FORMAN IS
SICK OF!!!" And this review as well. Onward!

Oh, before I go, c'I ask you something, Gary? What exactly is the
*deal* with "ping, ping, ping"?

======================================================================

"The Edifice"
-------------

My score for "The Edifice": 10 points out of 10.

Did I finish it?: About 2/3 done.

Notes to the author:
--------------------
The score should pretty much tell you what I found wrong with it (well,
a few minor bugs, but mail me privately for them), so let's focus on
what I *did* like, for a change.

This was an exceptional work of I-F in every way. Actually three
stories in one, with a short prologue, but unlike "Curses" or "Jigsaw"
it didn't feel at all disjointed. Its design is both stylish and fair:
Using the edifice to tie the game together was well-done, and I loved
being able to do the parts in any order.

Ingenious, original embellishment of objects with proper names,
especially clever since so much of I-F is played that way: "kill beast.
drop rock and spear." I *loved* it! Puzzles are challenging but fair,
offering nice backtracking capability, flexibility and meaningful
goals. My favorite was figuring out how to converse with Stranger.
Easily the most satisfying puzzle experience I've had all year, even
if I missed most of the third scene through my outright refusal to look
at the hints for the second. But I will finish it. This is a must-
finish.

See, people? It *is* still possible to do a good puzzle-based game,
and this is how you do it. Original, story-related problems, original
*story* (Angela M. Horns take note), good prose, satisfying gameplay, a
serious theme, it's all here. Perhaps a bit laid-back, not an action-
packed thrill ride. This works to its advantage, though, as I felt
comfortable taking my time. And I had so much more *fun* with this
story than anything else so far that it just had to get top score.

One teeny suggestion: Put some unexpected funny bits in somewhere.
I tried "KISS MOTHER" in great anticipation of receiving a hideous pun
about "Edifice Rex." (D'OH!!) Umm... Nah, on second thought, don't.
It'd probably just ruin it, and I've already used the stupid joke here.

Very, *very* nice job, Lucian. You deserve to win.

======================================================================

"The Town Dragon"
-----------------
-1 Reasonable solutions/actions not implemented.
Decent mobility with your NPCs, but their interactivity is sorely
lacking.

-1 Bugs/crashes.
Peter/Gary/Tom follows me on *every* turn, even if I'm not *going*
anywhere! Fix this, please. It bugged the hell outta me.

-1 Poor writing.
Not painful, but not interesting either. A few too many exit lists
for my comfort. Dragon scenes were pretty good.

-1 Cliched story/setting.
Fantasy world. 'Nuff said.

-1 Miscellaneous stuff that pissed me off.
I dunno, just... stuff. Little things. Like on the first move,
howzcome no matter what I do it doesn't print anything? And
sometimes the text isn't very clear when things happen, like when
you're transported to a different location, cuz it doesn't print the
room name or room text. And the spacing isn't nice and neat like I
like it. Why is there treasure scattered around where any idiot can
find it? Would I really be the very first to think of entering the
shed, or filching the mirror? Speaking of the mirror: It's a bit
arbitrary, the hint relying too much on my happening to be in the
saloon the same time as the mayor. Nice twist on mazes (though
"Curses" did something similar), but they're still out of style this
year. And, of course, there's the Oh-Gawd-Don't-Remind-Me "PtF"
situations.

My score for "The Town Dragon": 5 points out of 10.

Did I finish it?: Yes.

Notes to the author:
--------------------
This is another one that I wanted to rate higher than I did. Good
ideas (actually some very cute and clever ones), but not well
implemented. The entire game has a rough, unpolished feel to it, the
distinctive signature of unprofessionalism.

I loved the dragon carrying my companions away, and becoming a dragon
myself was kind of fun. Neat twist, too, not having to kill the
dragon, but this was still undermined by the treasure-hunting/damsel-
rescuing scenario. (Why are rescuers always male and rescuees always
female? Where's Xena when you need her?)

I liked the wrong-direction messages. Very tongue-in-cheek, which is a
must for this type of game anymore. (For *GOD'S* sake, don't anyone
try a serious fantasy game. It'll never make it, trust me.)

======================================================================

"Pintown"
---------
-1 "Guess the word."
Nouns this time. Not enough synonyms implemented. Objects
mentioned in the rooms aren't recognized. Also starting the car was
artificially harder than it had to be.

-1 Typos.
Just enough to keep me from getting into the game.

-1 Reasonable solutions/actions not implemented.
Why can't I play the guitar when I'm not in front of the kids? Why
can't I pet the cat? Why can't I use the stove? Why doesn't anyone
*say* anything when I talk to them?

-1 Bugs/crashes.
"START VAN" crashes the game. Trying to drive east or west after
I've left my building crashes the interpreter (rendering the game
unwinnable). After I've saved the cat from the boys, it can go
right back to them again (rendering the game unwinnable, since I no
longer have the guitar). I can get out of the van and give the beer
to the drunk guy, but the text still prints as if I'm driving. Did
you playtest this at all? If you did, remind me not to hire you to
test any of my I-F. 'Cept maybe "Sylenius Mysterium."

-1 Lacking "something really cool."
All of the cool parts were buggy.

-1 Miscellaneous stuff that pissed me off.
For God's sake, add a couple of line-feeds at the start of your
introductory text so it isn't immediately covered by the status
line. (How could you *not* notice this?)

My score for "Pintown": 4 points out of 10.

Did I finish?: Got in two hours of play (mostly screwing around with
workarounds for the bugs), but nowhere close to the end.

Notes to the author:
--------------------
Playtest, playtest, playtest! There is no sugar-free low-fat low-
cholesterol substitute for it. You rush it, you end up with a buggy
game that's not much fun to play. (Case in point: "Sylenius
Mysterium.")

"Pintown" reminded me of "The Broken String," albeit minus the
alternative (and potentially offensive) social viewpoints. Too bad
that's what made "Broken String" interesting. Stripped of these
elements, it becomes "Pintown," just another average save-the-cat,
patch-up-your-love-life Inform story by another average first-time
author who hasn't yet learned how to use the full capabilities of the
development system.

It's a pretty decent setting, too, one that deserves more detail than
you've provided. I like the film of decadence that seems to permeate
much of the game world. Cute reference, with the Solace Cafe (are you
an Effinger fan?) More vivid descriptions are in order.

Put some more effort into your NPCs. Orange is potentially
interesting, but aside from moving around, he doesn't *do* anything!
No one *says* anything! Give the kids some lines, to make them more
than cardboard props for a puzzle. Why aren't any of the characters
*animate*? The standard NPC verbs -- give, ask, tell, etc. -- don't
work for Jenny or Orange. To be honest, Sooty the cat was the most
interesting NPC in town.

Not having seen the whole game, I can't offer much more commentary.
Fix the bugs, then give me a ring.

======================================================================

"The Lost Spellmaker"
---------------------
-1 "Guess the word."
Obvious synonyms ("candy") overlooked. Also, it acts screwy when
trying to take one piece after another. Not sure if this is the
library or the game source.

-1 Poor design/construction.
Refer to my notes below.

-1 Cliched story/setting.
Fantasy village. Nuff said.

-1 Lacking "something really cool."
And it's frustrating, because the game obviously had the potential.

-1 Miscellaneous stuff that pissed me off.
That title screen. If I wanted to see letters dancing across the
screen, I'd turn on Sesame Street. Interesting from a coding
standpoint, and a surprise the first time you see it, but utterly
pointless. What's next, multimedia light shows with a soundtrack?
Next time, put more effort into your *game* than your title screen.

My score for "The Lost Spellmaker": 5 points out of 10.

Did I finish it?: Yes.

Notes to the author:
--------------------
Hoooo-KAY, lemme see here: We've got James Bond. We've got a Windhall-
esque fantasy village. We've got spells, a la "Enchanter". And we've
got a romance (about which more to follow). You've thrown a lot of
different ideas together but essentially done nothing with any of them.

The James Bond bit: Okay, this was the most imaginative part of the
game. I liked the setup, with the door appearing whenever I needed
help. I liked the way T told me just enough to let me feel as if I'd
solved the puzzles myself. I *didn't* like being thrust into a mission
with no supplies or weapons of any sort. Heck, all I needed for a
weapon, as it turns out, was a good sturdy book, but the agency
couldn't even spare that. Why not? Why isn't the fact that I'm a
secret agent tied into the game more?

The Windhall-esque fantasy village: A little *too* Windhall-esque.
The Reverend and his linguistic shortcomings just screamed "Sir
Gunther." Not that I'm accusing you of anything. I'm sure you haven't
played "Path to Fortune." Only three people in the world have, you
know. Why anyone would see "The Path to Fortune" as an I-F role model
is beyond me. But my point is... um, I guess I don't really have a
point. Except fantasy villages are boring.

(Does it seem like I'm bringing up "The Path to Fortune" a lot? Even
though the game is crap and I hate it, perhaps I'm subconsciously
projecting into these reviews my yearning to get it some of the
exposure I once felt it deserved and have someone, *anyone* notice it.
Just... try to ignore it.)

The spells, a la "Enchanter": Geez, for a game about spells, you'd
think I'd be able to *use* more than one measly smidgen of magic. The
"magic" angle, like the James Bond deal, was barely connected to the
rest of the game.

The romance: C'mon, what were you *thinking?* The lesbian romance was
a fascinating and *original* concept, but you didn't *do* anything with
it! It wouldn't have to be sexual, of course, but you could have
developed it more. As it stands, there's just the tiniest bit of
suggestion between Mattie and Tilly, then it's abandoned until the
endgame, where Tilly whacks the villain upside the head with a book,
which is somehow supposed to bring us together. *If* the player thinks
to lead Silk into the library, that is. But why would I do that, and
risk getting Tilly killed? I'm a secret agent, after all. I'm
supposed to beat the bad guy *without* taking out one-eighth of the
town's population in the process.

This brings up a problem that occurs throughout the whole game.
There's no *reason* behind the solutions to many of the puzzles. How
do I *know* the housekeeper will go make tea if I ask her? (Okay, I
think the author is British, but there should at least be a hint
*somewhere*.) How do I know the old woman wants the tea, and that
she'll trade the rope for it? How do I know Tilly will take out Silk
if I lead her into the library? (Who the heck *IS* Silk, anyway?
I didn't see any mention of her until I met up with her under the well.
That's another problem. Not enough backstory.)

Even where the puzzles *did* make sense (leading Daisy to the town
square), they were often plagued by coding problems. Why won't Daisy
simply follow me after I've given her a sweet? Why do I have to set up
the trail of candy beforehand? Why does she go back to the field once
the trail runs out instead of hanging around? I'd much rather wrestle
with the puzzles than the code, and in this case I had to do the
latter. Make it more flexible.

Speaking of the cow, she's awfully quick to insult my intelligence, but
doesn't even notice her own goof with the value of pi. Get yourself a
basic math text, Daisy, and, as the great sage Matt Barringer once
said, "look it up."

Yes, I got the anagrams, though in the future you might try making them
a bit more pronounceable, like "Zeke S. Vettenmyer" in TimeQuest, still
the best anagram in I-F history.

Put all of this together, and you get a game that feels like leftovers:
a bunch of scenes cut from a half dozen other games mixed together and
passed off as a complete work. I liked the selection of music in the
weaver's shop, but it only served to muddle the atmosphere even more.

Damn, I didn't say one positive thing here, did I? Well, the writing
was pretty good. The NPCs were pretty lively and responsive, if not
all that imaginative. The puzzles I didn't bash were well-implemented.
I just felt that this game could have been so much more, and I wished
it had been. Which is probably why my disappointment was so great and
why I'm bitching so much. You're a good I-F programmer. You have good
ideas. Just focus them a bit more clearly next time.

======================================================================

--
C.E. Forman cefo...@worldnet.att.net
Author of "Delusions", the 3rd place winner in the 1996 I-F Competition!!
Release 4 is now at: ftp://ftp.gmd.de/if-archive/games/infocom/Delusns.z5
Ye Olde Infocomme Shoppe http://netnow.micron.net/~jgoemmer/infoshop.html

C.E. Forman

unread,
Jan 10, 1998, 3:00:00 AM1/10/98
to

Mark J Musante

unread,
Jan 12, 1998, 3:00:00 AM1/12/98
to

C.E. Forman (cefo...@postoffice.worldnet.att.net) wrote:
> Kept getting TADS "out of memory" errors when running it with TR
> 2.2.0.4. Had to screw around putting TRX into my path to get it to
> work. Normally I wouldn't take off for this, but I couldn't quit
> TADS because of the memory errors, so I had to reboot my machine.
> I hate rebooting my machine. If I wanted to reboot my machine a
> lot, I'd install OS/2 on it. Plus *then* I hadta remember to use
> TRX each time I ran the game, or I'd end up rebooting *again*.

TADS has a special command: "$$ABEND" (must be in all caps) which will
immediately exit the runtime. Of course, this assues that you've
got a prompt at which to type. But it's better than nothing.


-=- Mark -=-

Reply all
Reply to author
Forward
0 new messages