[IFComp03] Michael's reviews (part 2 of 4)

2 views
Skip to first unread message

Michael Coyne

unread,
Nov 27, 2003, 2:18:20 AM11/27/03
to
REVIEWS IN THIS POST
Sardoria
Hercules First Labor
shadows on the mirror
little girl in the big world


---------------------------------------------------------------
Sardoria

Author: Anssi Raisanen
System: Alan

Tagline Summary: You return your cursor to the shell prompt and ascend
the directory tree.

What is up with Alan anyway? First APUS has really odd behaviour when I
try to restart, and now Sardoria does too, but it's not the same behaviour.

When I type 'restart' in a game, and the game then asks "Are you sure
(RETURN confirms) ?", I expect that typing 'y' or 'yes' and enter would
cause the game to restart. But no, you have to just hit enter. If you
dare respond to the question, the game will not restart.

The initial location seemed decent in terms of the way the location was
described. The steps are described as going up to the west, and in a
nice touch, both 'w' and 'u' take you there.

After struggling around searching in the basement for some time, I
finally resorted to the hints, which didn't help. I had already placed
the bottle on the steps, and I was struggling to find some way of
attracting someone's attention so that they would unlock the door and
come in, thus springing the trap. Knocking on the door, bashing it,
screaming, shouting, all to no avail.

Even placing the bottle on the steps is a pain; the game doesn't
understand 'put bottle on step', as 'step' is not a recognised word.
'Steps' is, but I envisioned it as putting the bottle on one step, not
multiple ones. Oh well.

I finally managed to find the key, after 'search ceiling', and at that
point, unlocked the door and was able to get out and have the game progress.

I persevered through a number of puzzles whose solutions seemed
arbitrary, or poorly clued. Pushing the tiles in particular was
frustrating, as the objects and tiles were all so similar and open to
wide interpretation. The lack of varied feedback from pushing the tiles
also contributed to this frustration.

I struggled through to the gate on the stairs, where a bug ended up
leaving me stranded (details in scoring section below).

Author Encouragement:
Thank you for not starting in a bedroom!

The writing in Sardoria is quite decent, serviceable to the story. I'm
continually shamed at these competently written games from non-native
English speakers. It makes me flush with embarrassment over some of the
things produced by people who've grown up speaking the language.

Better cluing of the puzzles would help. I would especially encourage
you to provide responses for things the player is likely to try that
aren't the solution. A good example would be when the player tries to
get the ham, only to be told "You can't reach the ham." This kind of
dismissive answer sounds like a "Don't worry about this item" kind of
response, and had me looking elsewhere for a solution to exiting the
kitchen. It might be better to indicate that the ham is out of reach,
but not by much, thus possibly pushing the player in the right direction
of trying a pot.

Scoring:
W: 3
Writing is competent, in terms of lack of spelling mistakes, proper
grammar. Story itself is unclear, PC motivation is unknown (though I
found out, post-comp, that 'x me' provides a little more detail--though
it makes me wonder why the game didn't begin with that blurb).

A: 2
This game was not terribly appealing. Lack of PC motivation resulting in
lack of player motivation. May also suffer from being played after
Sophie, Curse of Manorland and Apus. I'm tired of games with poor
implementation, completely unclued puzzles and items of interest buried
in the scenery.

B: 1
There were a few parser quirks, lots of guessing the verb required. One
major bug found that rendered the game unfinishable.

After opening the golden box, I messed with a few of the items (taking a
couple of them) before figuring out the right thing to do to open the
gate. The gate swung open, so I decided to continue up. The game
responded with "You return the jewels into the box and ascend the
staircase." This continued happening, and I was unable to move on. I
also tried 'enter gate', which resulted in "You return the jewels into
the box and pass through the gate."

I was never able to get past this point, even after trying to reclose
the box, replace the items, verify that I was empty-handed and so on. As
I also couldn't go back down, and the game provides no undo, I was very
neatly snookered.

E: 2
Puzzles make little or no sense to me. Again, it's hard to figure out
what items in the environment should be interacted with, objects are
buried in scenery, etc. In extreme cases, you don't even see certain
items until you examine other items. For example, examining the bed
reveals that there is a nightstand beside it.

If you try to go 's' from the kitchen, you get a warning message not to
do so. Who's to know that, once you're holding the lid, you are allowed
to proceed in that direction? Puzzles should be better clued, e.g.
looking at the ham hanging from the ceiling should give a clue that it
could be used as an offensive weapon, e.g. "The ham looms overhead,
large and dangerous. You feel a little apprehensive standing underneath it."

WABE score: 4


---------------------------------------------------------------
Hercules First Labor [sic]

Author: Robert Carl Brown
System: HTML (Javascript)

Tagline Summary: In homage to this game's method of displaying what
objects are in the room, let me just say that "I can also see: nothing
of interest."

An HTML game, that pays homage to Scott Adams adventures. Well, it
begins with the same unspecified plot that most SA games did, too, as
far as I can remember.

The first thing I notice is the edit box, prepended with "Tell me what
to do?", which is posed as a question, when it is really a command.
Never mind. I type 'about' for game information, only to discover that
hitting in the edit box does not result in the command getting
processed, at least not in Mozilla 1.4. So I continually have to hit
after typing my commands, and then . Annoying.

I tried it briefly in IE, but that was even more annoying, as IE takes
forever to process Javascript. In general, pages that are really long
parse seem to very poorly in IE (though Microsoft refuse to admit this
is a problem, but that's another story).

It's never a good sign when the initial location contains two objects
under the "I can also see" line, and when the first is examined, the
game responds "What ?!", and when the second is examined, the game
responds "I see nothing unusual." The room description itself is
likewise sparse, saying only "I'm in a Hotel Room in Bed". Of course,
'examine bed' results in "What ?!".

Eventually, I get up, to find myself "in a Hotel Room by Bed", where I
can also see "TV" and "Bed". By the way, have I mentioned that I dislike
odd capitalisations of objects in IF? Well, I do.

I 'examine television' only to receive "What ?!", a message I am rapidly
tiring of. 'Examine tv' works, but television is an obvious synonym that
should have been foreseen... especially as it's the "correct" name for
the device.

I explore the hotel room, which seems to be five or six completely
unnecessary locations, all of which mention their exits, but make no
mention of what is truly in that direction.

I eventually get to Mycenae, and figure out what I'm supposed to do.
Many, many pointless locations follow, with absolutely minimalist
descriptions, and pointless, confusing puzzles. In the rare places where
items or people are described with more than one word, the writing is
pretty insipid or downright confusing.

Consider the following response to 'examine molorchus':

Molorchus looks like you'd expect the poor workman he is.

Ouch!

The puzzles, such as they are, do not make a lot of sense to me, even
after the fact. I would never have figured out that I have to talk to
Molorchus more than once, because the first time I spoke to him, all he
said was "Welcome to Cleonae", leading me to believe that was all he was
there for. He then sends you to get the bow from his house. Fine, all
well and good, and I moved on, little realising that I needed to speak
to him again, so that the arrows would then magically appear at his
house. How did he do this, when I was just in the house and didn't see
them, and I know he hasn't left his post at the gate?

The kicker came near the end when, after wandering aimlessly around the
map trying to find the lion, I consulted the walkthrough and found that
I had to refer to an item that I hadn't seen through the whole game, and
which wasn't mentioned in my inventory, in order to proceed.

Author Encouragement:
A hotel room is pretty close to a bedroom, but not quite, so you earn a
thank you for not starting in a bedroom.

I admire the effort that went into creating your own parser in HTML, but
I think you might be better off with one of the established ones, if you
want your game to have wide audience appeal.

In addition, the homage to Scott Adams is very nice, but I believe we
have moved beyond that era. When I want a two-word parser game with
minimal descriptions, I dust off some of the old classics. But in a 2003
IFComp, I'm looking for a little more.

I just feel that by doing the homage, you've really limited yourself.
The parameters you've chosen for your entry don't really allow you to
properly demonstrate the writing skills you may have.

Scoring:
W: 1
The writing isn't great. Conversations lack any form of quotes,
descriptions for rooms are non-existent, and while locations make
mention of the available exits, they make no mention of what lies in
those directions.

Ultimately, there just isn't enough writing here to make any impression.
I will say however, that at least there weren't too many spelling
mistakes, compared to some of the other entries. That doesn't make it
good writing, but it at least makes it less painful.

A: 1
It's hard for a game to have much appeal, or immerse you in the story
with such short descriptions of everything.

B: 2
I really lost my enthusiasm for two-word parsers right around the time I
first played an Infocom game, in about 1983. I haven't revised my
opinion of them in the last twenty years. I don't like them. And having
a parser that responds "It's beyond my power to do that." if you attempt
to travel the wrong direction from a room is not my idea of fun. At the
very least, I want a "You can't go that way" message.

E: 1
I did not really gain any entertainment value from this game. Don't
forget, it's up against games with intriguing storylines, impressive
puzzles, engrossing NPCs, and engaging writing.

WABE score: 2.5


---------------------------------------------------------------
shadows on the mirror

Author: Chrysoula Tzavelas
System: TADS3

Tagline Summary: Played after Hercules First Labor, this game can't lose.

All right, this review is very brief, as I don't have too much to say
about this one that isn't favourable.

It was an interesting little game that I felt could benefit from a bit
more information revealed about the back-story. On the plus side, I
ended up replaying a number of times as a result, trying to glean all
the information.

The game was not terribly difficult except for realising the word I had
to use to examine a particular item on the NPC.

Author Encouragement:
What can I say? I really enjoyed this one. You should definitely feel
encouraged to write more.

Scoring:
W: 4.5
The writing really drew me into this story, in spite of my not being a
fan of character-interaction based IF. I spotted no obvious spelling or
grammatical errors, which was a welcome change.

A: 3.5
Interesting and appealing, but as mentioned, this isn't really my type
of IF. That being said, it was still very well done. Might be a 4 or 4.5
if I liked this sort of thing better.

B: 4
No bugs that I could spot. The only difficulty arose from not knowing
the word to use to examine a particular item on the NPC.

E: 4
Pretty entertaining, the story-telling being its biggest strength. Very
minimal, and no particularly complicated puzzles or anything.

WABE score: 8
This game may have benefited from being played after a few bad ones.


---------------------------------------------------------------
little girl in the big world

Author: Peter Wendrich
System: StoryFactory

Tagline Summary: Aw, isn't that cute?

I'm not sure what to make of this one. The dual point of view is a
little strange, resulting in being unsure how to proceed in some of the
puzzles.

The writing was okay. Its main strength was the depth of description for
a lot of the items in the game, albeit with awkward phrasing and some
really poor spelling in some spots.

All-in-all, fun without a lot of depth.

Author Encouragement:
It's cute, and the two-character viewpoint is interesting too. I'd be
interested to see this done in a more established system, such as Inform
or TADS, but really just out of curiosity.

The concept might be worth exploring as a full-length game, where some
actions need to be performed by Alice, and the others by... er, whatever
that other thing was. Of course, I think you'd need a definitive way to
switch viewpoints, so that if you tried something as Alice and it didn't
work, you could switch viewpoints and try with the other character.

Scoring:
W: 2.5
Serviceable writing, a few awkward phrases. This score would be higher
if the story was a little more compelling, or had more to it. There were
also quite a few spelling errors, the "it's/its" problem, spacing issues.

A: 2.5
Cute, in a brief "Zip! Was that it?" kind of way.

B: 2.5
Didn't find any outright bugs, but a lot of the puzzles seemed to have
arbitrary solutions, or weren't sufficiently clued (such as pulling the
clock).

E: 2.5
Some fun, but nothing special. It was likeable, but not consistently.

WABE score: 5


---------------------------------------------------------------
(continued in next message)

Michael Coyne

unread,
Nov 27, 2003, 2:18:20 AM11/27/03
to


---------------------------------------------------------------
Sardoria

WABE score: 4

hitting <ENTER> in the edit box does not result in the command getting

processed, at least not in Mozilla 1.4. So I continually have to hit

<TAB> after typing my commands, and then <ENTER>. Annoying.

Reply all
Reply to author
Forward
0 new messages