Could not find tools error

161 views
Skip to first unread message

Murat Doğan ŞAHİN

unread,
Apr 20, 2019, 2:42:31 PM4/20/19
to devtools
Hi,

When i try to download the updated version of simstudy package using devtools. I get the error massage: 

devtools::install_github("kgoldfeld/simstudy")
Downloading GitHub repo kgoldfeld/simstudy@master
Error: Could not find tools necessary to compile a package

Devtools package is up to date. I tried several ways but nothing chane. Can u pls help me?

Jim Hester

unread,
Apr 24, 2019, 9:10:15 AM4/24/19
to Murat Doğan ŞAHİN, devtools
The package you are trying to install contains compiled code which
requires a compiler to install.

There are detailed instructions on how to setup a dev environment at
https://whattheyforgot.org/set-up-an-r-dev-environment.html. In
particular you need to download and install RTools from
http://cran.r-project.org/bin/windows/Rtools/.

Jim
> --
> You received this message because you are subscribed to the Google Groups "devtools" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to rdevtools+...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages