Warning message: mclapply(content(x), FUN, …) : all scheduled cores encountered errors in user code

2202 views
Skip to first unread message

Weijia Chen

unread,
Aug 1, 2014, 3:06:52 AM8/1/14
to rdata...@googlegroups.com
I used "R and Data Mining: Examples and Case Studies"

My question is about Stemming Words: Chapter 10 Section 10.3

When I run the code: 

myCorpus <- tm_map(myCorpus, stemCompletion, dictionary = myCorpusCopy)

I got the Warning message:

In mclapply(content(x), FUN,) : all scheduled cores encountered errors in user code

When I run the code: inspect(myCorpus[11:15])

I got messages: "Error in UseMethod(\"words\") : \n no applicable method for 'words' applied to an object of class \"character\"\n" attr(,"class") "try-error" attr(,"condition")

The following link is a reproducible example which you can copy/paste into R and run.


How can I solve the problem? 

I'll be grateful with any help and appreciate the time you spend. :-)

Regards,
Weijia

mauro.gent...@gmail.com

unread,
Aug 10, 2014, 4:17:02 AM8/10/14
to rdata...@googlegroups.com
Hi, 

I have the exact same problem as Wijia.

All recommended libraries have been loaded but this does not fix the problem.
I used the tweets downloaded from the site (not my tweets).

I run R on Mac Maverick 10.9.3


> sessionInfo()
R version 3.1.1 (2014-07-10)
Platform: x86_64-apple-darwin13.1.0 (64-bit)

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] tm_0.6             NLP_0.1-3          twitteR_1.1.7      rjson_0.2.14       ROAuth_0.9.3       digest_0.6.4       RCurl_1.95-4.3    
 [8] bitops_1.0-6       RWekajars_3.7.11-1 rJava_0.9-6        RWeka_0.4-23       SnowballC_0.5     

loaded via a namespace (and not attached):
[1] grid_3.1.1     parallel_3.1.1 slam_0.1-32    tools_3.1.1   

Yanchang Zhao

unread,
Aug 10, 2014, 4:38:04 AM8/10/14
to rdata...@googlegroups.com
Reply all
Reply to author
Forward
0 new messages