papara install errors

29 views
Skip to first unread message

mfonse...@gmail.com

unread,
Aug 24, 2021, 1:50:03 PMAug 24
to raxml
Dear all, 
I am trying to install papara in my Mac (Catalina 10.15.4) and its not working.
I am following the building tutorial, but the program its not can install correctly the boost and consequently the papara is not compiling.
Anyone can help me with this?
Thanks a lot
Mariana

Dimitri

unread,
Aug 25, 2021, 10:35:35 AMAug 25
to raxml
Dear Mariana,

you could try the (unfortunately) standard Linux approach:
  • Get Boost 1.56.0 (as newer versions seem to cause problems), e.g. from here: https://sourceforge.net/projects/boost/files/boost/1.56.0/
  • Unpack and add the path of your Boost to the compile command in the build_papara2.sh
    such that it looks like this "g++ -o papara -O3 [...] -lpthread -I/path/to/boost_1_56_0/"
  • Execute build_papara2.sh
Kind regards,
Dimitri

Lucas Czech

unread,
Aug 25, 2021, 11:15:19 AMAug 25
to ra...@googlegroups.com

Hey Mariana,

have you also tried the pre-compiled version for Mac that you find here: https://cme.h-its.org/exelixis/web/software/papara/index.html in the top section "Download"?

Does that work? If not, what is the error message?

Cheers
Lucas

--
You received this message because you are subscribed to the Google Groups "raxml" group.
To unsubscribe from this group and stop receiving emails from it, send an email to raxml+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/raxml/2cb1318f-aabd-41e7-abf2-6d9013870d44n%40googlegroups.com.

Mariana Fonseca Rossi

unread,
Aug 26, 2021, 7:31:02 AMAug 26
to ra...@googlegroups.com
Hi Lucas, 
Yes, I tried. But appears this error message: Illegal instruction: 4

Cheers
Mariana



--
Mariana Fonseca Rossi
Professora Adjunta - 
Departamento de Zoologia
Laboratório de Protozoologia (LabProto)
Programa de Pós-Graduação em Biodiversidade e Conservação da Natureza
Instituto de Ciências Biológicas - Universidade Federal de Juiz de Fora

Mariana Fonseca Rossi

unread,
Aug 26, 2021, 7:55:18 AMAug 26
to ra...@googlegroups.com
Hi Dimitri, thank you so much.
It`s working now.
But even running ok, this error message appears.
Do you know what this is?

papara called as:

./papara -t arvore_1000pb.nwk -s Alinhamento.phy -q fragmentos_sun.fasta -n saida 

gap rate: 24430 338762

gap rate: 0.0721155

rate matrix: [2,2]((-0.0721155,0.0721155),(0.927884,-0.927884))

p: [2,2]((0.993137,0.0068627),(0.0882999,0.9117))

references container instantiated as: papara::references<pvec_pgap, sequence_model::tag_dna>

edges: 425

scoring scheme: -3 -1 2 -3

papara_core version 2.5

start scoring, using 1 threads

Illegal instruction: 4



Kings
Mariana

--
You received this message because you are subscribed to the Google Groups "raxml" group.
To unsubscribe from this group and stop receiving emails from it, send an email to raxml+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/raxml/2cb1318f-aabd-41e7-abf2-6d9013870d44n%40googlegroups.com.


--

Lucas Czech

unread,
Aug 26, 2021, 7:35:44 PMAug 26
to ra...@googlegroups.com

Hi Mariana,

that is a weird MacOS error... are you sure you are using the papara version that you just compiled following Dimitri's instructions? If so, there is no easy way for me to track down this issue, because I don't have a Mac... Dimitri, do you have access to one that is sufficiently recent (ideally Catalina 10.15.4, as Mariana is using that)?

There seem to be some compatibility issue, see here: https://stackoverflow.com/questions/14268887/what-is-the-illegal-instruction-4-error-and-why-does-mmacosx-version-min-10
Not sure if that helps, but it might be worth having a look at.

In the meantime, Mariana, do you have access to a Linux computer that you can use to run PaPaRa? That should work better.

So long
Lucas

Reply all
Reply to author
Forward
0 new messages