Failure for installation of Rapyuta

108 views
Skip to first unread message

scopus

unread,
Dec 4, 2015, 12:57:17 AM12/4/15
to rapyuta
Hi, all. I am using Ubuntu 12.04 which is run in VMware workstation. The ros-fuerte-desktop-full has been installed.
By following the instruction  http://www.rapyuta.org/install, I installed the rapyuta but failed. 
The errors are displayed bellow: 

....................
......................
.........................
Fetched 11.5 MB in 15s (762 kB/s)                                                                                               
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-fuerte-common-msgs : Depends: ros-fuerte-std-msgs but it is not going to be installed
                          Depends: ros-fuerte-langs but it is not going to be installed
 ros-fuerte-ros-comm : Depends: ros-fuerte-langs but it is not going to be installed
                       Depends: ros-fuerte-ros but it is not going to be installed
                       Depends: ros-fuerte-roscpp-core but it is not going to be installed
                       Depends: ros-fuerte-std-msgs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
/bin/bash: line 1: git: command not found
passwd: password expiry information changed.

I have tried to solve it by "sudo rosdep init", then "rosdep update", but it didn't work.

It would be very appreciated that anyone could give me an answer.

scopus

unread,
Dec 6, 2015, 9:33:20 PM12/6/15
to rapyuta
P.S The erros came out when running " ./setup provision all "

在 2015年12月4日星期五 UTC+8下午1:57:17,scopus写道:

Dominique Hunziker

unread,
Dec 7, 2015, 8:43:07 AM12/7/15
to rap...@googlegroups.com
Is this error happening while setting up the host filesystem or the container filesystem? What configuration are you using during the provision?

In any case, this an error from apt-get. In case of the host filesystem: Try to manually install ros-fuerte-common-msgs. In case of the container filesystem: Delete the created container filesystem and run the script again.

scopus

unread,
Dec 7, 2015, 10:39:35 PM12/7/15
to rapyuta

Hi,Dominique, Thank you very much for your reply!  Frankly, I am not so clear about your words. I don't know the difference between the host filesystem and container filesystem.
What I have done were same to the instructions in the link : http://rapyuta.org/install  I also have tried to install all ros packages displayed in above errors by "sudo apt-get install ros-fuerte-*". It showed all ros packages have been installed. 
I think the container filesystem you mentioned is the directory /opt/rce/container. I deleted it and  run "./setup/provision all" again, The same errors happened again. 

I also tried "sudo rce-make". It prompts "bash: /opt/ros/fuerte/setup.sh: No such file or directory". But I have installed ros-fuerte-destktop-full successfully, the path "/opt/ros/fuerte/setup.sh" is correct.
Looking forwards to your reply! I am eager to learn Rayputa and wanto run it successfully. 

在 2015年12月7日星期一 UTC+8下午9:43:07,Dominique Hunziker写道:

Scassero

unread,
Jan 28, 2016, 3:01:40 PM1/28/16
to rapyuta
Hi all, 

I'm having the same problem, "ros-groovy-comm has unmet dependencies" occurring during the ./setup/provision all step of the installation. 
As a result, ros is not installed into the container filesystem, hence the 
 "bash: /opt/ros/fuerte/setup.sh: No such file or directory" 
upon sudo rce-make

Repeated provision attempts yield the same results. 
Packages are listed as installed and ROS functioning correctly in home directory before chroot


configuration of provision:
y
/opt/rce/container/
ubuntu 12.04
ros groovy
aws

scopus, any leads?
Reply all
Reply to author
Forward
0 new messages