rapyuta installation error

115 views
Skip to first unread message

Nishant Kejriwal

unread,
Jan 10, 2014, 1:49:13 AM1/10/14
to rap...@googlegroups.com

I have been able to install rapyuta successfully and able to  run barcode tutorial also.
But after doing rce-make , i didnt exit properly... so it was not able to run rce-container
and always throws OSError for file existence.
So i am installing rapyuta again , but its giving me openvswitch fatal error.
I have written error output in terminal below :

The following packages were automatically installed and are no longer required:
  ps-engine linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic openni-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
FATAL: Module openvswitch not found.
 * Inserting openvswitch module
 * not removing bridge module because bridges exist (lxcbr0)
Module has probably not been built for this kernel.
For instructions, read
/usr/share/doc/openvswitch-datapath-source/README.Debian
FATAL: Module openvswitch not found.
 * Inserting openvswitch module
 * not removing bridge module because bridges exist (lxcbr0)
Traceback (most recent call last):
  File "./setup/provision", line 472, in <module>
    provision_container(config)
  File "./setup/provision", line 321, in provision_container
    check_call(cmd, shell=True)
  File "/usr/lib/python2.7/subprocess.py", line 511, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'sudo /etc/init.d/openvswitch-switch start' returned non-zero exit status 1


Kindly help.

Thanks
Nishant

Nishant Kejriwal

unread,
Jan 10, 2014, 3:05:46 AM1/10/14
to rap...@googlegroups.com
This problem is solved now.  This was a dependecy issue with openvswitch package.
I already had openvswitch-switch and openvswitch-common but i need to install
openvswitch-datapath-dkms and update the system.
Reply all
Reply to author
Forward
0 new messages