Missing Django.urls when installing

52 views
Skip to first unread message

tricky...@gmail.com

unread,
Oct 30, 2018, 1:17:53 PM10/30/18
to rapidsms
Folks, I ran into a problem setting up RapidSMS.  I received a ModuleNotFoundError: No module named django.urls after running " python manage.py syncdb".

Joy Adeniran

unread,
Oct 30, 2018, 6:59:15 PM10/30/18
to rapidsms
Are you using a virtual environment? If yes, has it been activated? Be sure to follow the documentation at readthedocs.

Christopher Collins

unread,
Oct 30, 2018, 7:23:39 PM10/30/18
to rapi...@googlegroups.com
Hey Joy, I did activate but will backtrack and verify. Thank you very much.

On Tue, Oct 30, 2018, 6:59 PM Joy Adeniran <tommy...@gmail.com> wrote:
Are you using a virtual environment? If yes, has it been activated? Be sure to follow the documentation at readthedocs.

--
You received this message because you are subscribed to the Google Groups "rapidsms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rapidsms+u...@googlegroups.com.
To post to this group, send email to rapi...@googlegroups.com.
Visit this group at https://groups.google.com/group/rapidsms.
For more options, visit https://groups.google.com/d/optout.

Christopher Collins

unread,
Nov 1, 2018, 4:42:09 PM11/1/18
to rapi...@googlegroups.com
Hey Joy, I reran the activate command and everything appears to run successfully.  However, when I ran the python manage.py syncdb (using the sudo command for permission), I get a Traceback message where  "from django.urls import reverse; ModuleNotFoundError: No module named "django.urls".

Issaka Faisal

unread,
Dec 4, 2018, 10:58:56 AM12/4/18
to rapidsms
I am also having this same issue, I followed the tutorial to the latter.

Allan Stockman rugano

unread,
Dec 17, 2018, 2:22:34 AM12/17/18
to rapidsms
It also depend on the version of Django you are using. Which one are you using ?

Allan Stockman rugano

unread,
Dec 17, 2018, 2:23:00 AM12/17/18
to rapidsms
Which Django version are you using ?

Issaka Faisal

unread,
Dec 17, 2018, 3:06:08 AM12/17/18
to rapi...@googlegroups.com
I am using the rapid sms template and the version is 1.8. I actually run the requirements file . Kindly send me a working environment.

--
You received this message because you are subscribed to the Google Groups "rapidsms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rapidsms+u...@googlegroups.com.
To post to this group, send email to rapi...@googlegroups.com.
Visit this group at https://groups.google.com/group/rapidsms.
For more options, visit https://groups.google.com/d/optout.
--
Kind Regards

Mr. Issaka Faisal
Senior Software/Systems Engineer
Ghana
 
 
Notice of Confidentiality:-

The information contained herein is intended only for the confidential use of the  recipient. If the reader of this message is neither the intended recipient, nor the person responsible for delivering it to the intended recipient, you are hereby notified that you have received this communication in error, and that any review, dissemination, distribution, or copying of this  communication is strictly prohibited. If you receive this in error,please notify the sender immediately by telephone, and destroy this e-mail message OR reply with the subject “REMOVE” such that your email would be taken out of our distribution list.
Reply all
Reply to author
Forward
0 new messages