--
You received this message because you are subscribed to the Google Groups "rapidftr" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rapidftr+u...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
I think the usual advice from Cucumber enthusiasts is to avoid web_steps-type steps and prefer custom steps that express user intentions in domain terms. This is supposed to make your features easier to read and maintain, but it means you spend a lot more time creating steps. It also breaks down a bit when an application provides multiple ways of doing the same thing, though that only requires a minor compromise. (Hopefully we don't have that issue in RapidFTR.)
I agree something like Page Object Model could help make the steps and the application easier to read, write, and change.
For historical background, I believe web_steps was generated by Cucumber-Rails with a warning about not modifying it because it could be overwritten in an upgrade, hence more_web_steps.