Configuration grub-pc window

60 views
Skip to first unread message

Jamie Orchard-Hays

unread,
Jun 16, 2015, 12:01:28 PM6/16/15
to railsmachin...@googlegroups.com
Ubuntu 14.

Using same image I used two months ago, I'm now getting an installer config window showing up on cap deploy:setup, which is messing up the installation. I didn't have this two months ago. I have updated to current Moonshine. Any ideas?

Package configuration

┌──────────────────────────┤ Configuring grub-pc ├──────────────────────────┐
│ A new version of configuration file /etc/default/grub is available, but │
│ the version installed currently has been locally modified. │
│ │
│ What do you want to do about modified configuration file grub? │
│ │
│ install the package maintainer's version │
│ keep the local version currently installed │
│ show the differences between the versions │
│ show a side-by-side difference between the versions │
│ show a 3-way difference between available versions │
│ do a 3-way merge between available versions (experimental) │
│ start a new shell to examine the situation │
│ │
│ │
│ <Ok> │

Bryan Traywick

unread,
Jun 16, 2015, 12:10:19 PM6/16/15
to railsmachin...@googlegroups.com
It looks like grub is being upgraded during the deploy setup since it is out of date. This isn’t something that moonshine is doing just occurring because there is an update available for the package. Log into the server and run `sudo apt-get upgrade`. This will allow you to answer the questions about updating grub, then you should be able to successfully run `cap deploy:setup`.

— Bryan Traywick
> --
> You received this message because you are subscribed to the Google Groups "Moonshine" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to railsmachine-moon...@googlegroups.com.
> To post to this group, send email to railsmachin...@googlegroups.com.
> Visit this group at http://groups.google.com/group/railsmachine-moonshine.
> For more options, visit https://groups.google.com/d/optout.

Jamie Orchard-Hays

unread,
Jun 16, 2015, 12:19:13 PM6/16/15
to railsmachin...@googlegroups.com
Yup. I kept the old one. No idea if I should let it upgrade. The diff shown was

root=UUID=xxxx

commented out in new version and not in current. I kept current.

Jamie
Reply all
Reply to author
Forward
0 new messages