RailsInstaller is still running on ruby 2.3.3. New ruby is 2.6.4

115 views
Skip to first unread message

James Oneyibo

unread,
Sep 15, 2019, 7:02:23 AM9/15/19
to RailsInstaller
Hello, when is the railsInstaller going to be updated along with the current Ruby version which is 2.6.4. I had projects done with ruby 2.6.4 version and I cannot run them on windows as there is no way to install railsinstaller with the current ruby version. I have tried several options in installing the current ruby and then rails. but I am faced with problems specifically this:

ERROR:  Error installing rails:
        ERROR: Failed to build gem native extension.

    current directory: C:/tools/ruby26/lib/ruby/gems/2.6.0/gems/nio4r-2.5.1/ext/nio4r
C:/tools/ruby26/bin/ruby.exe -I C:/tools/ruby26/lib/ruby/site_ruby/2.6.0 -r ./siteconf20190915-12824-1gfhksd.rb extconf.rb

current directory: C:/tools/ruby26/lib/ruby/gems/2.6.0/gems/nio4r-2.5.1/ext/nio4r
make "DESTDIR=" clean
current directory: C:/tools/ruby26/lib/ruby/gems/2.6.0/gems/nio4r-2.5.1/ext/nio4r
make "DESTDIR="
make failedNo such file or directory - make "DESTDIR="

Gem files will remain installed in C:/tools/ruby26/lib/ruby/gems/2.6.0/gems/nio4r-2.5.1 for inspection.
Results logged to C:/tools/ruby26/lib/ruby/gems/2.6.0/extensions/x64-mingw32/2.6.0/nio4r-2.5.1/gem_make.out



Any idea to fix this will be appreciated.

Darrell Sanderlin

unread,
Sep 15, 2019, 8:09:44 AM9/15/19
to railsin...@googlegroups.com
Best advice i can give is to setup your computer for dual boot. I had many of the same problems with windows. Have been happy dual boot ubuntu.

--
You received this message because you are subscribed to the Google Groups "RailsInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to railsinstalle...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/railsinstaller/4755493b-8e76-4fce-bfa9-c3fcc04a0383%40googlegroups.com.

James Oneyibo

unread,
Sep 15, 2019, 8:54:48 AM9/15/19
to RailsInstaller
Thanks Darrell. Been thinking of that too. I was hoping I won't have to do that.
To unsubscribe from this group and stop receiving emails from it, send an email to railsin...@googlegroups.com.

mmerlin

unread,
Sep 15, 2019, 9:08:59 PM9/15/19
to RailsInstaller
Another option is a virtual machine.  Instead of dual boot.  I use virtualbox, but other options available too.
Reply all
Reply to author
Forward
0 new messages